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Application/Purpose: 

Procedures listed in this manual allow IC eDNA Monitoring Program staff the ability to edit 
(QA/QC) field collected data. 

Roles and Responsibilities: 

Only eDNA Leads are responsible for editing data. 

1.0 ArcGIS Pro 2.8.3 

1.1 Start a New Project Template 

Start an ArcGIS Pro (Pro) Map Template by selecting Map from the Blank Templates list. 
Give the project a unique name (ex: La Crosse FWCO eDNA 2022), specify the location of 
where to store the Pro project file, and create a folder if needed to store the project file and 
eDNA field data. Click Ok when finished. 

1.2 Folder Connections 

The folder specified to store your project file will automatically show under the Folders option in 
the Catalog Pane. If the Catalog Pane does not appear on the right side in Pro, go to the View Tab 
and Select Catalog Pane in the Windows group. 

 
1) To establish a new folder connection, right click on Folders in the Catalog Pane and select 

Add Folder Connection to connect to a folder on the computer. 
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2) “Add Folder Connection” window will appear which will allow you to navigate and 
select the folder of interest. Click Ok and the folder will be added to the Catalog Pane 
under Folders. 

 
3) To Connect to a Folder not stored on the Computer, Copy the folder path to the 

folder of interest and paste the path into the Name box and click Ok. The folder 
will be added to the Catalog Pane under Folders. 

2.0 eDNA Fisheries ArcGIS Online Web Map 

2.1 Access ArcGIS eDNA Fisheries Online Web Map 

1) To access the online Fisheries eDNA Sampling map through Pro, the individual 
needs to be logged into the ArcGIS Online account by going to the top right-hand 
corner of the Pro screen and expand the Not signed in menu (see below). Select 
Sign In. The sign in process is the same as signing into the Field Maps App (refer to 
Field Maps App Log in Section 1.2). 

 
2) After signing in, go to the Catalog Pane, Select Portal from the top menu (see below). 
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3) Next, Select the My Groups Icon. 

 
4) In the Search bar, type in Fisheries eDNA Sampling and hit enter. Right click on the 

Fisheries eDNA Sampling Map to open the map in Pro (see below). 

 
3.0 Select and QA/QC Individual Office eDNA Data 

3.1 Common Errors Checklist 

Common errors to look for in the invasive carp eDNA field data feature layer when conducting 
QA/QC checks in ArcGIS Pro. 

1) Check the map and ensure all your sample points are displaying on the targeted 
waterbody. 

2) Snap blank samples to the appropriate field data point if not already snapped. 
3) Check state line layer in map to ensure the correct state has been identified for the 

sampling point. 
4) Check for null values in each data field. 
5) Check the date collected column for any dates and times outside of the date/time range of 

collection. 
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6) Look for repeat Regional Unique ID’s.
7) Make sure calculate geometry has been run on the Latitude and Longitude fields.
8) Please make note of any environmental conditions that may affect the quality of the

samples in the comments field.

3.2 Create Local Copy for Editing 

A local copy of the data needs to be created before editing the eDNA sample points. 

1) Select the Fisheries eDNA Sampling Map tab (tab should be highlighted in blue).
2) Zoom in to the extent of the sampling points. Make sure all the sampling points can

be viewed in the map extent. It is important to zoom-in to the area of interest that
needs to be edited since the local copy created will be based off the current extent
displayed in Pro.

3) Next, Download an offline copy of the map by selecting download under the
download map tool in the Offline group under the Map tab in Pro. Leave the
Include basemap and tile layers box unchecked (see image below).

4) The offline map download is successful if the Sync and Remove options are
no longer greyed out under the Offline Group (see image below).

Important! Double check to make sure only the targeted office data has been downloaded by 
using the Select by Attributes tool to check the Sampling Station ID Code field only has one office 
value (La Crosse FWCO, Ashland FWCO, etc.). Sampling Points are also color coded by sampling 
Basin. See Section 3.3.2 Select by Attributes. 

3.3 QA/QC of eDNA Data: Identifying Data Issues in Pro 

3.3.1 Attribute Table 

1) Right click on the feature layer to open the attribute table (see image below).
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2) Right click on each field to sort the data ascending and descending to check for null or 

incorrect values (see images below). 
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3) To fix a data value, click on the data record in the table to edit the value. If multiple data 
values need to be changed (batch edit records) then see Section  3.4.1 Using the Calculate 
Field Tool. If editing the date collected field, pay attention to the date and time field and 
ensure both are accurate (see image below). 

 

. 
After making changes to the table, go to the Edit Tab in the top ribbon of Pro. Select Save under 
the Manage Edits Group to save edits. Use the Discard Edits to undo any edits made. 

 
3.3.2 Select by Attributes 

1) Right click on the feature layer to open the attribute table (see image below). 
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2) Select the Select By Attributes tool in the table header (see image below). Select 

by   attributes can also be accessed in the Map tab under the Selection group in 
Pro. 

 
3) The Select by Attribute tool can be used to query for certain records in the database 

to check for null values or check for data accuracy. In this example, the Selection type 
New selection is chosen, so the resulting selection replaces the current selection. In 
the Expression clause (Where), the field Regional Unique ID (RUID) is chosen, with 
the operator "is equal to". Then unique RUIDs can be chosen from the Values list to 
select values equal to the RUID in the Expression clause. 
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4) A value for RUID can then be selected from the list of values and then select Apply
to highlight the record in the table (see image below).

5) Check for null values in the data by setting the expression to is null (see image below).
Null values can also be found using the ascending and descending functions for each field

(see Section 3.3.1). Run this expression on each of the data fields to make sure data is 
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complete. If running this expression doesn’t highlight any of the records, then the data 
has a value entered for the respective field. 

 

6) Use the Select by Attributes on multiple fields to check records for completeness and 
accuracy. Add Clause can be used in the tool to select more than one record by using 
the Or or And Clause (see image above). 

3.3.3 Find Duplicate Records 

1) Go to the Analysis tab in the top ribbon. Select Tools from the Geoprocessing group 
(see image below).  

 

2) Use the Find Tools search box in the Geoprocessing pane to find the Find Identical tool.  

 



12 

3) Select the Find Identical Tool. Input in the Feature Layer and navigate to a folder to
store the output dataset. Input the Regional Unique ID as the field. Check the box
output only duplicated records (see image below). Select Run.

4) If no identical values are found, the tool will complete with a warning: Find Identical Tool
completed with warnings. Check the View Details and expand the messages group to
ensure it reads “Warning empty output generated.”, meaning no duplicates were found
(see images below). The output table will have no records in it when opened.
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5) If there are identical values in Regional Unique ID field, the tool will
complete successfully with no warning messages.

6) Open the output table in the Contents Pane in Pro by right clicking the table then
select open (see image below).

7) If there were duplicate records, the IN_FID Field matches to the OBJECTID field from the
USFWS Region 4 Fisheries eDNA Sampling feature layer and the FEAT_SEQ groups the
same duplicate records by number (see image below). For example, IN_FID (OBJECTID) 7
and 8 are the same duplicate record due to the 1 appearing in each of the FEAT_SEQ.

3.4 QA/QC of eDNA Data: Editing in Pro 

3.4.1 Using the Calculate Field Tool 

1) Use the Calculate Field Tool to change multiple records at once. Select the records
that      need to be changed through Select by Attribute or by manually selecting the
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gray boxes by each record (see image above), then right click on the field of 
interest and select Calculate Field (see image below).  

2) Enter in the information that will populate the selected records in the blank box,
change the expression type from SQL to Python 3 in the Calculate Field window
(see below) and leave all other inputs as default. If the information is text put
quotes around the text. Make sure to Enable Undo by toggling to blue. Select Ok to
change the records (see image below).
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3) Only the selected records will have the changed information from the Calculate 

Field tool (see below). Clear the selection in attribute table or under the Selection 
group in the Map tab.  

 

4) Save Edits under the Edit tab in Pro or Discard Edits if a mistake was made. 

3.4.2 Calculate Geometry 

1) Use the Calculate Geometry tool to populate the Latitude and Longitude fields. If a 
point is added or moved after running Calculate Geometry. The coordinates need to 
be updated in the latitude and longitude fields (re-run the Calculate Geometry 
tool). 
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2) To update the latitude and longitude values, right click on either the Latitude or 

Longitude field and select Calculate Geometry (see image above). 
3) Enter in Latitude and Longitude for the Target fields with Point y-coordinate for 

Latitude and Point x-coordinate for Longitude. Set the Coordinate Format to Decimal 
Degrees and select Ok (see image below).
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4) The coordinates will be updated in the Latitude and Longitude fields. 

3.4.3 Creating a Feature Point 

If a sample point was not submitted in the field or missing, a point can be created for that 
sample in Pro.  
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1) Go to the Edit tab in the project. Click on the Create Features tool under the
Features Group (see image above).

2) The Create Features Panel will appear on the right in the project. Select one of the
appropriate Basins to add a new feature under the FWS Region 3 Fisheries eDNA
Sampling Feature layer to add a point to the map.

3) Next, Use the Active Template to fill out whether the sample is a blank or not. If
the blank attribute field is not filled in you will get an error message. Then, click a
spot on the map to add the new point (see image below).
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4) Use the Active Template (image above) or the Attribute table to fill out the
rest of the tabular data (see image below).

If there are specific coordinates associated with the sample point then the Absolute X, 
Y, Z option can be used to add them. 

1) Open the Create Features Panel.
2) Select New Feature in the Panel and then right click anywhere on the map and

choose the Absolute X, Y, Z option.
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3) In the Absolute X, Y window, use the drop-down arrow to select decimal degrees (dd). 
4) Enter the latitude and longitude of the point and press enter when finished. The point will 

appear in the specified location. 

 
Make sure to leave the W and N at the end of each coordinate and leave the negative sign 
out for the Longitude. 

5) Save Edits under the Manage Edits group. Or Discard edits if a mistake was made. 
Exit the Create Features Panel to stop adding new features. Important! Update 
coordinates using Calculate Geometry. 

3.4.4 Moving a Feature Point 

1) Turn off the State Reference layer in the Contents Panel (see image below). 
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2) To move a sample point, use the Select tool under the Selection group under the Edit 

tab to select the point. 
3) Next, Select the Move tool under the Tools group in the Edit tab. 
4) Use the mouse to click and drag the point to a new location on the map. Select the 

Finish option in the tool dialog box to change the location of the point. Important! 
Update coordinates using Calculate Geometry. Save the Edits.  

 
5) If the point has a specific coordinate location that it needs to be moved to, right click 

the selected point, and select the Edit Vertices option (see image below). 
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6) An Edit Vertices Panel should appear. Next, hover the mouse arrow over the selected point 

until an arrow icon appears. Then right click the point to bring up an options window. 
7) Select the Move To option on the options window (see image below). 

 
8) In the Move To window, use the drop-down arrow to select decimal degrees (dd). 

Enter the latitude and longitude of the point and press enter when finished. 
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9) The point will appear in the specified location. A highlighted point will remain in the 
previous location the point was at and can be removed by selecting the Clear 
selection under the Selection group under the Edit tab or by right clicking on the 
selected point and select Move. Important! Update coordinates using Calculate 
Geometry. 

3.4.5 Snapping Feature Points Together 

1) First Turn Snapping on under the Snapping Group under the Edit tab. 
Make sure the snapping is On and the point snap option is on (highlighted 
in blue when on). 

 
2) Follow Section 3.4.4 to move a sample point on top of another sample point 

to snap the points together. A circle will appear around the point being 
snapped to (see below). Once snapped, the points will share the exact same 
latitude and longitude. Important! Update coordinates using Calculate 
Geometry. 

 
3.4.6 Appending Data to Geodatabase (Field Maps App or I-Pad fails) 

1) If data needed to be collected outside of the Field Maps App due to a severe technical 
issue, record the data on a paper data sheet and transcribe the field data to the 
provided Excel sheet located on the R3 eDNA SharePoint Site under ArcGIS 
Resources. 
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Note: If needed, coordinates can be captured as waypoints on a fish finder. Match the 
waypoint number to the eDNA sample to keep track of sample locations. Export the 
waypoints to add the coordinates to the provided Excel sheet. Enter in the Comments 
what device was used to capture coordinates and in what datum. 

2) QA/QC the data in Excel using similar tools such as Sort and Find and Replace to 
identify null values, duplicate RUID values, and incorrect data entries. Double 
check coordinates. 

3) Send the final QA/QC excel file to the eDNA database manager, Jeena Koenig 
(jeena_koenig@fws.gov). The data will be added to the final database on the 
FWS Enterprise Warehouse and in AGOL if the data is reportable. 

4.0 Uploading QA/QC eDNA Data to ArcGIS Online 

1) Once all the edits have been made, save edits under the Edit tab in the Manage 
Edits group. 

2) Optional: Export either a table or feature layer of the final data to your office data 
repository by right clicking on the feature layer and selecting the data option to 
either export a feature layer or a table (see next page). Or use the Table to Excel 
tool. Make sure to select the domain and subtype description option in the Table to 
Excel tool (see images below).  

Note: Make sure the selection is cleared before exporting the data.
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3) The data can then be uploaded back to ArcGIS Online (AGOL) by going to the map 

tab and selecting Sync under the Offline group. 

 
4) The mobile geodatabase will need to be deleted after the remove option is selected 

for removing the local copy of the feature layer. 

 
5) Save the Pro Project with the Fisheries eDNA Sampling Map to use again for 

future editing. Re-add the online web map that contains the eDNA feature layer 
if newly created feature points do not appear. 

Note: When accessing the online web map, make sure to download a local copy of the 
data when editing is needed. Previously downloaded local copies may not reflect data 
that has been  collected after the local copy was created. 

Note: Make sure to Sync the feature layer to AGOL and then remove the offline copy 
when finished with the editing process. Please don’t leave mobile geodatabases 
unresolved on the computer. Non-reportable data is any data not published to the 
public facing AGOL feature layer or the U.S. Fish and Wildlife Service eDNA website. 
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