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Unit 12 
Search - How to Create & 

Edit 
 
 
 
  



 

239 | P a g e  

 

  



  

240 | P a g e  

 

Overview 
In this section we will learn to create a Search Results Page. A Search Results Page is used for creating a search avenue for either your 
specific refuge site or all of the refuges. This is done using the NWRS_Search Widget. 
 

Content Definition: Dynamically generated content pages based on users’ keyword search. All elements on this page are 

dynamically generated; the web author will not need to produce these pages. 

 

Search Results has a pre-set list of widgets that will be available to web authors which includes:  

NWRS_Search Widget 

 

Special Notes: A modified version of this template will be used for the aggregate News Page of the sites. The News Page will 

include a drop-down that will allow users to sort news items by year. 

 

Section Use: Search Results, News Page 

 
  



 

241 | P a g e  

 

 

Exercises 
Exercise 12-1: Create/Edit Search Page  
In this exercise we will create/edit the Search Results page. 
 

1. To edit the Map page. Navigate to Your Refuge > Section > Search folder and edit the page. Refer to Unit 14: 
Working with Content - Managing Content & Page - Edit PageBuilder Page for detailed instructions. Skip to Exercise 
12-2: Add/Edit Search Widget section below. 

2. To create a new Search Results page navigate to Sections > Search. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Choose New > Page Layout 
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4. Add New Page: 
A. Choose three column layout 
B. Click Next 

 
 
 

5. Title, Aliasing, and Taxonomy: 
A. Enter a page title into the Page Title Field. This is the name of your content block. 
B. The alias field is automatically populated when you enter in a page title. Modify this alias so it follows the URL Aliasing 

Standards defined in Unite 3: URL Aliasing Standards. 
C. Click Next 
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6. Metadata  – Refer to Unit 14: Managing Content/Page Properties - Adding Metadata to add the Metadata. Click Finish when 
Metadata is completed 

 

7. Click OK 
 
 
 
 
 
 
 
 
 

 
 

 
 

Exercise 12-2: Add/Edit Search Widget  
In this exercise we will add the NWRS search widget to your new PageBuilder page. To edit the NWRS_Search Widget, skip to Step 4. 

 

1. Click the arrow in the top left corner of the page to open the PageBuilder fly out menu. This will allow you to access your widget 
tray. 

 
 
 
 
 
 
 
 
 
 
 

2. Click the arrows in the middle of the menu bar to drop down your widget tray 
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3. Locate the NWRS_Search widget in the menu. Click and drag the widget to the center of the blue bo

 
4. Hover over the first white square and a pencil icon will appear click on it 
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5. Click on the folder tab 
 

 
 

 

6. Navigate to Your Refuge Folder Double click Your Refuge  Folder then click the Properties tab 

 

 
 

 

7. In the Page size field enter in the number of results to be displayed per page. 
Click Save 
 

 
 

 

8. Select File > Publish 
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Here is an example of how your Search Page will look. 
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Unit 13 
Managing Site Navigation 
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Overview 
The refuge site has been designed to use combination of both the Ektron Smartform and Menu to provide the overall site 
navigation. It was designed this way to simplify the management of the Refuge site navigation. The Refuge Navigation 
consists of the Site Wide (Global) Navigation and Sectional Navigation.  

 Global Navigation - comprised of the Main navigation, Footer navigation and Persistent navigation which are on 
every page of your refuge site. The menu items of the Global Navigation is managed from the Homepage – Main 
Navigation section of the Refuge Homepage Smartform content located in the Home folder of your refuge folder 
structure. 

 Sectional Navigation - also referred as the Left Navigation, displays only on the sectional pages (as left navigation). 
The Refuge Section Configuration SmartForm content located in the Section Configuration folder is used to turn the 
left navigation On or Off, define the background illustration and which section the left navigation is applicable to. 
The Menu items for the Sectional Navigation are managed using the Refuge Menu. 

 

Managing Site Wide Navigation 
Main Navigation 
The Main Navigation is the horizontal menu that displays on every page and consists of Visit, Wildlife & Habitat, Seasons of 
Wildlife and About the Refuge. Visitors who click on any of these menus, with exception of Visit, will send them to the 
sections landing page. The Visit menu displays a drop down menu with links to sub-sections of the Visit section.  

 

The Main navigation is managed through the refuge site home page “Refuge Homepage” smart form. From there you will be 
able to manage: 

 Visit – Turn On/Off Visit menu and add the required and optional Visit sub-menu links 

 Wildlife & Habitat – specify the link of the Wildlife & Habitat landing page 

 Seasons of Wildlife – specify the link of the Seasons of Wildlife landing page. This page is optional 

 About the Refuge – specify the link of the About the Refuge landing page 

 

Please refer to the Unit 10 “Homepage – Editing the Homepage” for instructions on how to modify the Main navigation 
settings. 
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Footer Navigation 
The Footer Navigation is the menu that displays at the bottom of every page and contain various refuge, regional and 
departmental links. The Footer navigation is managed through the refuge site home page “Refuge Homepage” smart form. 
From there you will be able to manage: 

 Regional Office – specify the link to the Regional Office 

 Contact Us – specify the link to the “Contact Us” page 

 News – specify the link to the News landing page. This page is optional 

 Jobs – specify the link to the Jobs landing page. This page is optional 

 FAQs – specify the link to the FAQs landing page. This page is optional 

 

Please refer to the Unit 10 “Footer Navigation Settings” for instructions on how to modify the navigation settings for the 
footer. 
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Persistent Navigation 
The Persistent Navigation is the menus that displays on the Persistent column (right side) of every page and contains “What 
We Do” and “Featured Pages” or “Related Pages”. What We Do is a required menu and will display on all pages. “Featured 
Pages” is an optional menu and will only display in the homepage. “Related Pages” displays on any other pages and is an 
optional menu. 

 

What We Do 
Please refer to the “What We Do Navigation Settings” section for instructions on managing the menu. 

  

Featured & Related Pages 
The Featured Pages (Homepage) and Related Pages (All Pages) menus display in the Right Column of all pages. The Featured 
Pages section of the Homepage will be used to highlight articles while the Related Pages section of all pages is used to show 
related articles to the primary article being displayed. Both Featured and Related Pages are managed exactly the same way 
except Featured Pages is only applicable to the Homepage. Refer to the following sections for instructions on how to manage 
the respective menu: 

 

Featured Pages Related Pages 
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 Featured Pages: Unit 10, Adding Featured Pages Links section has instructions on how to add Featured Pages. 
 

 Related Pages: Unit 4, Adding Related Pages Links section has instructions on how to add Related Pages. 
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Managing the Refuge Section Configuration  
The Section Navigation is the left hand navigation that you see in section pages and will be referred to as Left Navigation also. 
The left navigation displays menu items for that section, providing further directional to relevant information residing within 
section. The coloring for the left hand navigation is based on the site color palette you selected when editing the homepage. 
All the sectional navigation follows the color palette selected with exception of “Visit” which will always remain light blue. 

 

By design, all the Sectional Navigation (Left Navigation) has been created for you. The primary actions you will perform for 
the Left Navigation will from the Section Configuration content and the Sectional Menu. They are: 

 Section Configuration content  
o Turn Left Navigation on or off 
o Change the Left Navigation background illustration 

 Sectional Menu 
o Add, Re-order or remove menu items from the Left Navigation 

Section Navigation Options 
 The CMS Editor will have the ability to: 

 Create a new section/left navigation menu 

 Turn On or Off the left navigation 

 Specify the left navigation background illustration 

 Pick menu items that will be display for that menu 

 Set which menu the section left navigation will display 

 Specify the applicable section for the left navigation menu 

 

Creating/Editing Section Navigation Configuration 
The section navigation is specified in a configuration file using the “Refuge Section Configuration” smart form. Each section of 
your web site should already have been created and configured so this step may not be necessary. If the section 
configuration has already been created and configured for you, focus on adding Menu Items (individual menu links in the 
section) to your existing Sectional (Left) Navigation.  Use the following steps to create a new sectional navigation if a new 
section is being added or if you deleted a sectional configuration by accident. 
 
NOTE: The left navigational menu is the same on every page in a given section of the site.  Every section in the Visit section can have its 
own menu (or none). You can also add a list of links to the content area of a page if you need additional navigation. 

 

1. Open the Workarea and click on the Content tab. 
2. Navigate to the Sections Configuration folder under your Refuge folder 
3. Within the Sections Configuration folder you will see a configuration file for each section of your site. If you are 

editing existing configuration file skip to step 5. 
4. Go to New menu and select Refuge Section Configuration and that form will open. Perform this step ONLY if you are 

creating a new section. 
5. From the list of configurations, select the configuration to be edited and click on the gray arrow next to the 

configuration title and select Edit from the fly out window. 
6. Add or modify the necessary settings. See procedures below. 
7. Click Publish located in the top left of the editor. The configuration changes will not take place until it has been 

published 
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Use this snapshot and options as reference for all procedures below: 

 

The following procedures have been broken down into individual procedures and each starts off with Edit and ends with 
Publish of the Section Configuration for ease of use. These individual procedures can be combined into a single procedure as 
desired by completing all procedures before publishing. 

Select Section Folder ID 
Use this instruction to specify which Sectional Folder (for example: Multimedia) this configuration applies to. 

1. Select and Edit the Refuge Sectional Configuration content for the section you want to turn On or Off. 

2. Section Folder ID – click on the browser folder icon  and a “Select Folder” window will appear 
3. Navigate to the Section folder that this configuration will apply to, select it, and click Ok 
4. The folder name and ID will now appear in the Section Folder ID field 
5. Publish the Sectional Configuration Content. 
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Turn On or Off a Left Navigation 
1. Select and Edit the Refuge Sectional Configuration content for the section you want to turn On or Off. 
2. In the Show Menu section, select Yes (display menu) or No (hide menu) from the drop down menu. 
3. Publish the Sectional Configuration Content. 

Select Menu to be Used for Left Navigation 
1. Select your Refuge Folder from the folder structure. 
2. Go to View > Menu.  

 
3. Click your Refuge Menu name and your menu structure will display. There should only be one Refuge menu to 

select. 
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4. From the list of sub-menu items, find Sectional Menu that you want to use as the Left Navigation.  
For example: Visit – For Educators 

 
5. Copy or write down the Menu ID number for the Sectional Menu. For example 526. 
6. Edit your Refuge Section Configuration for Visit – For Educators in this example. 
7. Paste or type in the Menu ID in the Menu ID field. 
8. Publish the Sectional Configuration Content. 

 

Turn On or Off Background Illustration 
1. Select and Edit the Refuge Sectional Configuration content for the section you want to turn On or Off. 
2. In the Show Illustration section, select Yes (display background) or No (hide background) from the drop down menu.  
3. Publish the Sectional Configuration Content. 

Specify the Left Navigation background illustration 
1. Select and Edit the Refuge Sectional Configuration content for the section you want to turn On or Off. 
2. Go to the Show Illustration section. 
3. Select the background Illustration you want displayed for the left navigation from the Illustration drop down list. 

Illustration Options are found in Unit 1 – Illustration Options. 
4. Publish the Sectional Configuration Content. 

Select Section for the Left Navigation 
This option will allow you to select which Section the Menu will be assigned to. If Visit is selected a Sub-section drop down 
will appear so you can select the Visit Sub-section the menu will apply to. 

1. Select and Edit the Refuge Sectional Configuration content for the section you want to turn On or Off. 
2. In the Section area, select the applicable Section and Sub-section. For example: Visit (Section) and For Educators 

(Sub-section). 
3. Publish the Sectional Configuration Content. 
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Editing the Left Navigation Menu 
The Section Left Navigation Menu is part of the overall Refuge Menu. Refer to Managing Refuge Menu below for instructions 
on creating/deleting menu, adding/removing menu items and re-ordering menu items. 
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Managing Refuge Menu 
The Refuge Menu is the container that contains the Main and Left Navigation. Each Refuge site already comes pre-configured 
with the standard Main and Left Navigation already built out for you and will only require you to edit existing menu items or 
add new menu items.  

 

This chapter will start off with description of the tools available to you to manage your Refuge menu then followed detailed 
step by step instructions. 

Accessing Refuge Menu 
The Refuge Menu is the primary container that contains all menu items including your Section Navigation (left menu). By 
default, this menu is hidden from normal view and you must enable the menu view to see your Refuge Menu. To view your 
Refuge Menu, follow the below steps: 

1. Login into your site and go to the Workarea.  

2. Click the Content Tab. 

3. Click on your Main Refuge Folder from the folder structure. 
4. Go to View > Menu.  

 
5. Click your Refuge Menu name and your menu structure will display. There should only be one Refuge menu to 

select. 
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6. List of all Sectional Menus will appear. 

 

 

Menu Toolbar 
Each menu is managed using the tools provided in the Menu Toolbar. The following illustrations detail the function of each 
feature. 

 

 

  - Add Items. Used to add Content Item, External Hyperlink or Sub Menu. Library Asset is a menu item option 
you can add but will never use. 

  - Remove Items. Used to remove menu items from a menu or sub menu. This is not a delete option. 

  - Reorder Menu Items. Used to change menu item order. 

  - Menu Properties. Used to view or edit the properties of the selected menu. 

  - Delete Menu. Used to delete the selected Menu.  
CAUTION! Do NOT use this option unless you are absolutely sure that you want to delete the selected menu. If you 
delete a menu, you will have to recreate the menu and update the Refuge Section Configuration with the new menu 
ID number. 

Note: When adding or editing menu use the right click menu BACK option and not the browsers back button.  

 

Menu Icons 
The following illustration will show you icons associated with the various menu items and sub menu. Use these illustrations 
to assist you in quickly identifying the type of menu item you are working with. 

  - Content Item. Content Item is a link to page which you will select from the Library. See Adding a Page Link as 
Menu Item below. 
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  - External Hyperlink. This menu is an internal or external link. See Adding External or Internal Link as a Menu 
Item below. 

  - Sub Menu. All the Refuge Sectional Navigations are Sub Menus. Sub Menu is the only menu option that can 
have additional menu items residing underneath it. See Adding a Sub Menu below. 

 

Editing Left Navigation Menu 
1. Access your Refuge Menu. 

2. Click on the Sectional Navigation you want to edit. For example: Visit – Educators. 

 

3. Sectional Menu items will display. Use the Add, Remove, and Re-order features to manage the menu items for the 
section. 

4. Follow the below instructions to add, remove and re-order menu items. 
 

Adding a Page Link as Menu Item 
This option will be the most common method to add menu items (links to pages) to your Left Navigation. 

1. Click on Sectional menu to add menu item to. For example: Visit – For Educators. 

2. Select the Add Items ( ). 

3. Choose Content Item and click the Next button. 

4. Browse to the folder structure to the folder containing the page you want to add. For example, the folder path can 
look like this: \Region 6\NWRS\Prairie Zone\Quivira\Sections\Visit\For Educators. 

5. Select the page\content to be added. For example: Check the box next to the For Educators content.  

Note: You can also add DMS documents (uploaded files) to the menu. 

6. Click the Add button ( ) to add the content items to the menu. 
 

Adding External or Internal Link as a Menu Item 
Use this option to add an internal or external (hyperlink) links. You need to know the full URL as you will have to type that in. 
This option allows you to edit the URL after it has been added. 

1. Click on Sectional menu to add menu item to. For example: Visit – For Educators. 
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2. Select the Add Items ( ). 
3. Choose External Hyperlink and click the Next button. Though the option is labeled External Hyperlink, this option 

can be used for both internal and external links. 
4. Enter in the Menu Title 
5. Enter in the URL. Two Rules to follow when entering the URL: 

a) External Links – enter in the fully qualified URL. For example: http://www.google.com 
b) Internal Links – enter in the relative path (the domain is assumed) URL. For example: 

refuge/Quivira/Visit/For_Educatiors.html. 

6. Click the Save button ( ). 

 

Adding a Sub Menu 
Sub-menu is used when you want to add a menu that can have menu items underneath it. This menu option should be used 
in your sectional left navigation in situations where you build out a sub-section with additional detailed pages which should 
appear in the left navigation. 

1. Click on Sectional menu to add Sub Menu item to. For example: Visit – For Educators. 

2. Select the Add Items ( ). 
3. Choose Sub Menu and Click Next. 
4. Enter Sub Menu Title in the Title field. 
5. Manually enter in the URL or select the page from the Library (click on the Link icon to access the Library) that will be 

associated with this Sub Menu. If there will not be an associated page for this Sub Menu leave the URL Link field 
blank. 

 

6. Click the Save button ( ). You will now be in the View Menu mode for the Sub Menu you just created. 

7. To add menu items to the Sub Menu, Click Add Items ( ).  
8. To add menu items to the sub menu use the Adding Content/Page as Menu Item or Adding External or Internal 

Link as a Menu Item instructions above. 
 

Editing a Menu Item 
There may be instances where you would need to edit a menu item. Follow these rules for when to edit a menu item: 

 Open a menu item in a new window. 

 If menu item was added using the content item option, you cannot edit the URL link. You must remove the menu 
item and add the correct link using the Add Item option. 

http://www.google.com/
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 If menu item was added using the External Hyperlink option, you can edit the menu item link. 

 

1. Click on the Sectional Menu you want to edit. 

2. Click on the menu item to be edited and you will automatically be entered into edit mode for that menu. 

3. Change Target or URL link. 

4. Click the Save button ( ). 
 

Reordering Menu Items 

1. Select the Reorder Icon ( ) to shift the content items 

2. Select a menu item. 

3. Use the Up or Down arrow on the right to move that item up or down the order. Note that “Sub Menu” is 
included in the list. 

4. Click the Update button ( ) when done. 

 
 

Removing a Menu Item from a Menu 
This option will only remove menu items, to remove a sub menu from a menu you must delete it using the Deleting a Menu 
instruction below. 

1. Click the Sectional Menu to be modified. 

2. Click the Remove Items button ( ) on the Menu Toolbar. 

3. List of all the menu items will appear. 

4. Check the box next to the menu item to be removed. 

5. Click the Remove Items button ( ) on the Menu Toolbar and the selected menu items will be removed. 

Note: Be careful not to choose the Delete Menu ( ) button that will remove the entire menu.  

 

Deleting a Menu 
This option should only be used to remove a sub menu that is no longer needed or was added by accident. 
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1. Select the Sub Menu to be deleted.  

 

2. Click Delete Menu ( ) to remove the menu. 

CAUTION! Do NOT use this option unless you are absolutely sure that you want to delete the selected menu. If you delete a 
menu, you will have to recreate the menu and update the Refuge Section Configuration with the new menu ID number. 

 

How to Create a Refuge Section Navigation 
There may be a situation where you will need to create a Refuge Section Navigation because a new section will be added or 
you accidentally deleted an existing one. All the instructions have been outlined on how to create a menu items, all it entails 
is the sequence that it must be created in and creating or updating the correct configuration. Follow the below instructions to 
create a Refuge Section Navigation. 

 

1. Access your Main Refuge Menu. Instructions can be found at Accessing Refuge Menu section. 
2. Click on Add Items button and an Add New Item window will appear. 
3. Follow the instructions in Adding a Sub Menu section to create/recreate the Refuge Section Navigation. For 

Example: Visit – For Educators. 
4. Add the relevant links for pages in the Sectional Navigation that will appear as Left Menu using the following 

options: 
a. Adding a Page Link as Menu Item 
b. Adding External or Internal Link as a Menu Item 
c. Adding a Sub Menu  

5. Add or Update your Section Menu ID using the instructions in the Select Menu to be Used for Left Navigation 
section. 
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Unit 14 
Working With Content 
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Managing Content & Pages 
This Unit contains instructions on creating/editing various types of content that resides within your refuge site. These 
contents that are created and shown in this unit are typically supporting content; they are part of a page but not the page 
itself.  

Adding HTML Content 
Reference: “Adding HTML Content” 
(http://documentation.ektron.com/cms400/v802/WebHelp/Managing%20Content/Adding%20Content/content_add.htm) 
section in Ektron CMS400.NET Reference Manual.  

 

1. Browse to the folder where you want to create the new content. 
2. Choose New > HTML Content. 

 
3. The Edit Content window opens. 
4. Create content just like you would when using a word processor. 
5. Publish. 

 

Editing Content 
Instructions for Editing Content apply to all content types: HTML Content, HTML Forms, Uploaded files via DMS, etc… 

Reference: “Editing HTML Content” 
(http://documentation.ektron.com/cms400/v802/WebHelp/Managing%20Content/Editing%20Content/content_edit.htm)  
section in Ektron CMS400.NET Reference Manual. 

Editing in a Web Browser 

1. Click on the Access Point on a page in your site. 

2. From the menu, choose Edit. The Edit Content window will appear with the content ready to be edited. 

3. Change the content by entering “Ektron training day.” 

4. Click the Publish button ( ).  The page now shows the changes. 

http://documentation.ektron.com/cms400/v802/WebHelp/Managing%20Content/Adding%20Content/content_add.htm
http://documentation.ektron.com/cms400/v802/WebHelp/Managing%20Content/Adding%20Content/content_add.htm
http://documentation.ektron.com/cms400/v802/WebHelp/Managing%20Content/Editing%20Content/content_edit.htm
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Do not use the Red  in the upper right corner of the window to close the Workarea. It is best to go to your browser and 
logout rather than exit using this window control. If you use this to close a content edit window, the content will remain in a 
“checked out” status. 

Editing in the Workarea 

1. Open the Workarea. 

2. Select the Content tab in the upper right portion of the page  

3. Navigate to the your site. 

4. Click on the arrow ( ) to the right of the content you wish to edit. 

5. Click the Edit choice to enter edit mode for this content. 

6. Make changes to the content. 

7. After you finish editing, click the Publish button ( ). The edited content will appear as soon as you refresh the 
page in your browser. 
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Creating a PageBuilder Page 
The following instruction explains step by step on how to create a PageBuilder page. Your refuge is provided with the 
following PageBuilder pages by default: 

 Refuge Map page 

 News page 

 Search Results page 

 Multimedia Listing page 
 

For more information about PageBuilder page and widgets go to: Unit 3: Page Types - Pagebuilder and Widgets 

 
1. To create a new PageBuilder page navigate to Your Refuge > Folder X where Folder X denotes the folder or sub-folder where 

the page will be created. 
 

  
2. Choose New > Page Layout 
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4. Add New Page: 

A. Choose two or three column layout 

B. Click Next 

5.  
 
 

6. Title, Aliasing, and Taxonomy: 

A. Enter a page title into the Page Title Field 

B. The alias field is automatically populated but can be updated. Update the alias following the URL Aliasing standard 
defined in Unit 3: URL Aliasing Standards. 

C. Click Next 
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8. Metadata: Fill out the Metadata fields using Unit 14: Managing Content/Page Properties - Adding Metadata as a reference. 

 
9. Click OK 

 
 

10. The newly created PageBuilder page will open in Edit Page Layout mode. 
 

 
 

11. Add widget(s) to the Dropzone and edit the widget to display content, list, map, etc… 
12. To Preview the page before you publish it, go to the PageBuilder fly out menu bar and select View > Preview Layout. 
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13. To return to Edit Page Layout Mode, select View > Return to Editing from the PageBuilder Menu bar. 
 

 
 

14. To Publish the page, select File > Publish from the PageBuilder Menu Bar. 
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Edit PageBuilder Page 
There are two methods to edit a PageBuilder page 1) From the page 2) From Workarea. 

 

Edit from Page 
1. Navigate your refuge site to the page that will be edited. 
2. Click on the blue nub located in the upper left corner of the PageBuilder page to open the PageBuilder fly out 

toolbar. 
 

 
 

3. PageBuilder Toolbar will appear. 
 

 
 

4. Select File > Edit. 
 

 
 

5. When complete with editing of the page. Select File > Publish from the PageBuilder Toolbar. 

 

Edit PageBuilder Page from Workarea 
1. Navigate your refuge site to the folder that contains your PageBuilder page. 
2. Click on the Title of the page and the page will be opened in View mode. 

NOTE: You can verify that the page you selected is a PageBuilder page because the Content Type is set to Page 
Layout. 
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3. Click the Edit Page Layout icon on the toolbar. 
 

 
 

4. Page will open in Edit Page Layout mode. 
5. When complete with editing of the page. Select File > Publish from the PageBuilder Toolbar.  
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Previewing Content 

1. This tool bar appears while editing content. You can Publish, Check-in, Save, Preview content or cancel your 
changes. 

 

2. Select Preview( ) to see your content as it will look when you publish it. 

3. The content appears in the default template - in this case, threecolumn.aspx. 
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Create/Edit a List using Three Column List 
SmartForm 
The Three Column List SmartForm is used to create a list box of up to three columns and added as supporting list box to 
pages. Your refuge site has been provided with two examples on the usage of the list box: 1) Multimedia Pages – Browse 
Multimedia by Subject and 2) Map Page – Additional Maps. These Three Column List SmartForm content can only be used 
in PageBuilder pages.  

 

The following instruction set shows you how to create a columned list box using the Three Column List SmartForm. For 
this example we will be creating an Additional Maps list box.  
 

 

1. Navigate to Sections > Maps.  
 

 
2. Select  New > Three Column List 
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3. Create a columned list using the Three Column List SmartForm. 

Three Column List SmartForm  

 
 

A. List Title: Enter in a title for your list.  

B. Editor ( ) Button: Located in the upper left hand corner will allow you to move around or remove content blocks. 

 

 

 

 

 

 

 

 

C. Links: add a link to your section content block.  

i. To add a link click on the Link ( ) button this will open up your link manager. 

ii. Next click on the URL ( ) Button.  

iii. That will lead into the library; make sure you are in Quicklinks. 

iv. Navigate to Library > NWRS > Your Refuge > Sections > X 

v. Make sure your Quicklinks are activated. 

vi. Double click on your link and then hit OK on the Link Manager Screen. 

 

D. Additional Text: Room for some additional information.  

E. File Size: Optional and will allow you to enter in the size of your file that you might display. 

F. Column: This allows you to choose the number of columns to display.  
 

 
 

 

 

 

1. Will give you option to assign this Column Item to Column 1-3. 

2. Use the drop down menu to choose how many columns you want to display. 

G. To add a new Column Item use Click the Column Item ( ) button. 

4. To publish your new list content Click the Publish ( ) button. 
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5. Add the list box content to PageBuilder page using Content Block widget. Below is an example of the Map Page in published 
mode and page layout edit mode. 
NOTE: Multimedia pages have the list box content (Browse Multimedia Section) added automatically and require no action on 
your part besides editing the list box content. 

 

Here are some examples how your page appears on the website: 
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This page was intentionally left blank. 
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Creating HTML Forms  
Reference: the “Working with HTML Forms” in the Ektron CMS400.NET Reference Manual. 
Forms, Polls and Surveys allow you to collect specific information from the visitors to your site. They can be very useful for 
creating mailing lists and obtaining feedback on various topics.  

Note: Employess must follow the DOI rules prior to creating a form and collecting information. See the www.fws.gov homepage (top 

left corner, Email the USFWS Customer Service Center) as an example. 

Creating a Form  
 

1. Click on Workarea > Content tab, select the “Forms” folder. 

2. Go to New > HTML Form/Survey. Note the 5 step indicator in the tool bar. 

a. Select Blank Form, then click the Next button. 

b. Enter title “Contact Me form”, then click the Next button. 

c. Leave the Assign Task as unassigned and click the Next button. 

d. Leave the default post back message; we’ll make changes to it later. Click the Next button. 

e. The setup is complete. Click the Done button. You will have an empty form like the following 
figure: 

 

http://www.fws.gov/
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6. Highlight Place form elements here… and remove it. 

 

7. In the first line of the design area, enter “Please enter your contact information below and one of our agents 
will contact you.” 

Notice the form fields are located on the bottom tool bar to the right starting with the Text Field. 

8. Press <Enter> to go to the next line. 

9. Enter “Your Name: “. 

10. Add a Text Field by clicking the Text Field icon ( ). 

11. In the popup window, enter the fields of information as follows: 
Descriptive Name: “Name”,  
Field Name: “name” 
Tool Tip Text: “Please enter your name” 
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12. Select the Validation Tab and set it to Cannot be blank.  

 

13. Click OK.  

14. Press <Enter> to go to the next line. 

15. Enter the text “Your Phone:” 

16. Add another Text Field to the right of the text.Pl 
Descriptive Name: “Phone” 
Field Name: “phone” 
Tool Tip Text: “Enter your phone number” 

17. Choose the Validation tab. Set the Validation to Telephone Number (US & Canada) (required). 

18. Click OK . 

19. Press <Enter> to go to the next line 

20. Enter “Your e-mail: “. 

21. Add a Text Field. 

22. Add another text field to the right of the text. 
Descriptive Name: “Email” 
Field Name: “email” 
Tool Tip Text: “Enter your email address” 

23. Choose the Validation Tab. Set the Validation to E-mail address (required). 

 

24. Click OK . 

25. Press <Enter> to go to the next line. 

26. Enter “Date you prefer to be contacted: ” 
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27. Add a Calendar Field ( ). 
Descriptive Name: “Date”  
Field Name: ContactDate 
Tool Tip Text: “What date do you wish us to call?” 
Default Value: (Leave blank) 

28. Choose the Validation Tab. Set the Validation to Cannot be blank. 

29. Click OK and go to the next line. 

30. Enter “Select time frame: ” 

31. Add a Choices Field ( ). 
Descriptive Name: “Timeframe”,  
Field Name: “timeframe” 
Tool Tip Text: “Please select a time frame”  

 

32. Add items to the Item list: “Morning”, “Afternoon”, “Evening”. (Use the +Option button (  ) to add 
fields to the list.) 
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33. Choose Appearance - DROP LIST. 

34. Click OK and go to the next line. 

35. Enter “Comments:” 

36. Add a Text Field. 
Descriptive Name: “Comments”,  
Field Name:  “comments” 
Tool Tip Text: “Please enter your comments”  

Options: Enable Allow Multiple Lines 
Dimensions: Set Width = 60 and Height = 4 
Leave the Validation as No validation. 

37. Click OK. 

38. The form will look something like this. 

 

39. Click on the Alias tab. 

40. Enter in the Alias for the form. 

 

41. Click Publish. 
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Creating a Post Back Message 
1. With the form open for edit, click on the Post back message tab. 

2. Choose Display a message. 

3. Delete “Place post back message here…” in the design area. 

4. Enter the post back message as shown below. 

NOTE: Click the Merge field button ( ) to choose fields from the form to enter. 

 

 

5. The fields in blue boxes can be added by selecting the field in the Merge Field dropdown shown:  

 

6. Publish your new form. 
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Changing Mail Properties of a HTML Form 
1. Once the form is created, reopen the form by clicking on the name of the form. Do not use the dropdown Edit 

option. 

2. From the View Forms Toolbar, click the Edit Properties button ( ) which is located three icons from the 
left.  

 

Note: This button is different from the Edit button. 

3. Select the Mail Properties Tab.  

 

4. In To field; add the Refuge’s email address. 

5. In CC field, add your email address. This is to ensure that the email went through properly. Test this once and 
then you can remove your email address from the CC field. 

6. In the From: field, enter in refuge email address 

7. In the Subject: field; enter in the subject for the email. 

8. Click on the Form Properties tab. 

9. Disable the Autofill form values option in the Form Data section. 

10. Click the Save button ).  

11. To view the new form: 

a. Navigate to your Refuge Forms folder and click on the form to view.  

b. Go to View Properties for the form. 

c. In a browser, enter the URL: 

 http://cmsstage.fws.doi.net/refuge/RefugeName/forms/contactUs.aspx 

number of the form you created. 

a. The “Contact Me” form page will appear. 

9. Enter the information and click the Submit Form button. Your post back message will be displayed. Your 
SMTP1 (mail transfer) protocol has already been configured for you.” 

 

http://cmsstage.fws.doi.net/refuge/RefugeName/forms/contactUs.aspx
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Exporting HTML Form data 
1. Navigate to your Refuge Forms folder. 

2. Click on the name of the form. Do not use the dropdown menu Edit. 

3. Click on the Report ( ) button to see the Forms Report. 

4. Click on Report Display drop down and select the display option that you want the report displayed as, and 
then click the Get Report button. 

5. Click the Export Report button. 

(This is an example form) 

 

 Save the new spreadsheet on your desktop. 
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Managing Content/Page Properties 
Each and every content or page that you create has its own associated properties which serve specific functions. They are 
Summary, Metadata, Alias, Scheduling, Comment and Templates. For most part NWRS CMS Editors will primarily focus on 
Alias, Metadata, Schedule, Comment and Summary in the order of priority. Templates have been pre-configured and 
should be ignored.  

 Alias – This is where you create your manual alias for your page/content. 

 Metadata – Enter keywords and description for SEO purpose and to define association used for Featured/Related 
Pages and Calendar Item / Event Details relationship. 

 Schedule – Gives ability to schedule Go Live date & time and Expire date & time.  

 Comment – Add comment on what you changed every time you edit content/page. Easy to track what was 
changed in the content/page version history. 

 Summary – Provide brief overview of content/page. Commonly used in list boxes that display page title and 
summary. 

Following is an example of Content Properties.  

 

Creating a URL Alias 
Follow the standards defined in Unit 3 URL Aliasing Standards when creating your URL Aliases for your pages. 

 
1. Create a new page or edit an existing page. 
2. Select the Alias tab. 
3. Type in the manual alias using the above standards and rules as a reference. 

 
4. Publish the page. 
5. To check the Alias, click the Alias Tab and click on the URL Alias. This will open up the page with the alias in the 

URL Address field. 
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Adding Metadata 
Metadata is primarily used in two ways in your refuge site 1) Descriptive metadata is used for Search Engine Optimization 
(SEO) and 2) Relational metadata is use to define one to one relationship between contents/pages. Specifically, this 
option is used for Featured/Related Pages and associating Event Detail content with a Calendar Item content. 

There are five metadata definitions used in your refuge sites that you should be aware of, they are listed below with 
explanations of how you will use them. All these metadata are optional. 

 Keyword – Used for SEO 

 Description – Used for SEO 

 Related Pages – Used for Featured Pages for Homepage and Related Pages for Sectional Pages. 

 Photo Credit - Used to display the Photo Credits residing on that page. 

 EventContent – Used to define relationship between Event Details content and Calendar Item content. 
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Keyword 
1. Click the Metadata tab. 
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2. To Add Keywords: 

A. In the keywords metadata field enter in keywords for the content/page you are creating. For example, if 
you are creating a page describing the Black-capped Vireo that resides Wichita Mountain Refuge. You 
could add the following keywords: Black-capped Vireo, Bird, Endangered, Wichita Mountain Refuge, etc. 

B. Single keyword or keyword phrase can be added. Click on the green + have each entry. 
3. To Edit Keywords 

A. Highlight the keyword or phrase. 
B. Update the keyword or phrase in the Text field. 
C. Click on Edit and it will update the existing keyword or phrase. 

4. To Remove Keywords 
A. Highlight the keyword or phrase. 
B. Click on Remove and it will be removed. 

5. To restore the Default, click the Default button and the default keywords will be restored. For your refuge sites 
no default keywords were specified so it will remove all keywords and leave it blank. 

6. Click Publish when complete. 
 

Description 
1. Click the Metadata tab. 

 
2. To Add Description simple type in one or two sentence summary of the topic of the page. 
3. To restore the default, click the Default button. The default is empty so it will remove what you have in the 

Description field.  
4. Click Publish. 
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Related Pages  
In the right column of most pages there is a Related Pages section that displays links to pages that are related to the 
primary content. The Homepage uses the Related Pages metadata but is displayed as Featured Pages. This section is 
optional and will display only if you have assigned related pages. 

 
 

1. Edit your refuge Homepage SmartForm to update your Featured Pages or the page where Related Pages will be 
updated. 

2. Select the Metadata Tab. 
 

 
 

3. Click the Edit icon in the Related Pages section and the Library window will open in Quicklinks mode 

 

4. Navigate to the page link that that you want to insert as Featured/Related Pages and select the link so it appears 
in the bottom right frame of the window. Multiple page links can be added so it appears in the bottom right 
frame.  

5. Click the Save icon when done in the Reorder and Finalize Selections section. 
6. The Featured/Related Pages links have been added. Click on the Publish icon to publish the page. 

 

Photo Credits Metadata – Add Photo Credits to a Page 
Photo credits can be added to any pages that contain images. The following instructions should be used to add Photo 
Credits to any pages you may create. Use the Add an Image section of Unit 14 for instructions on how to add Photo Credit 
description and Unit 3 – Photo Credits section for Photo Credit standard and formatting. 
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6. Edit the page to add the photo credit to. 

7. Select the Metadata tab 
 

 

8. Click the Edit icon in the Photo Credit section and the Library window will open in images mode 

9. Navigate to the image that is used on the page and select the image so it appears in the bottom right frame of 
the window. Multiple images can be added so it appears in the bottom right frame. Click the Save icon in the 
Reorder and Finalize Selection section when done. 
 

 

10. The photo credits have been added.  Click on the Publish icon to publish the page. 
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EventContent Metadata 
The EventContent Metadata is used to define a relationship between an Event Details content and Calendar Item content. 
Exercise: 7-5 Associate an Event Detail with a Calendar Event provides step by step instructions.   
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Content Scheduling 
1. Click the Schedule tab. 

 

2. Click the Select a Date and Time button ( ) next to the End Date. 

3. In the pop up window, select a date and hour you want this content to be archived. 

4. Click Done. 

5. Select the radio button Archive and remove from site (expire). 

6. If you publish the content at this point, the schedule will apply. 

Note: Before proceeding with other exercises in class, REMOVE the schedule date by clicking the Delete the Date and Time button (

). This will allow you to see this content in the next lessons. 
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Adding Comments to Content 
Comments are used for internal communication about content and are not visible to visitors to the site. Comments make 
it easier and faster to determine the changes made between versions of the content.  

1. Click the Comment tab. 

 

2. Enter your comments in the Comment box.  

3. Click the Publish button ( ) in the tool bar.  
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Adding Summary Information 
Summary information is text that sometimes appears in Search Results and when “Teaser Text” is shown on ListSummary 
or Collections. Adjust this text in any way you choose. If the summary is blank, it is filled in automatically with 
approximately the first 40 words of the text in the main content.  
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Uploading Files 
Ektron provides you with two ways you can upload files, the Document Management System (DMS) and the Library. 
Which mechanism to use to upload and manage files depends on whether you want more capabilities to manage the files 
when uploaded into Ektron. Follow these simple rules to assist you in making a decision: 

 Use the Library for simplicity as it involves uploading and linking to page you will use the file at.  

 Use the DMS if you want more functionality like version control, move file to another location, play audio/video 
files on web page without need for visitor to have audio/video player on their computer. 

 

Most of the refuge sites will be uploading files like pdf or Multimedia files. For all Multimedia use the Library to upload 
and manage the Audio and Video files. Due to bandwidth and server resource usage by Audio and Video running on your 
web servers, it is recommended that you consider using video hosting service like YouTube. 

Uploading File Using DMS 
1. In your Test Folder select New > DMS 

Document. 

2. For the title type in Sample Document. 

3. Click the Browse option to browse to a 
document or image on your desktop. 

4. Add  information into the other tabs such as 
summary and metadata. 

5. Then Publish this document. 

6. You will see Sample Document as a piece of 
content in your Test folder. 
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Note: Multiple DMS Document option from the NEW menu is only supported if Microsoft Office 2003 or greater is 
installed and Internet Explorer is used. If you are using Firefox you must install a Firefox drag and drop plugin to have 
multiple file upload capability. 
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Uploading File to the Library 
1. In the Workarea select the Library tab. 

2. Navigate to the folder that the file will be uploaded to. 

3. From the drop down list, select files. 

4. Click the Add button ( ).The Add Library Item window appears. 

 

5. Click the Browse button to browse your local or network drives for the file to be uploaded. 

6. Enter a title for the file. 

7. Add description of the file in the description field.  

8. Click the Save button ( ). The file is added to the Library. 

 

 

Uploading an Image to the Library 
1. In the Workarea select the Library tab. 

2. Navigate to the folder that the image will be uploaded to. 

3. From the drop down list, select Images. 

4. Click the Add button ( ).The Add Library Item window appears. 
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5. Click the Browse button to browse your local or network drives to locate an image. 

6. Enter a title for the image 

7. The Description field is used for Photo credits. Add the Photo credits. The following are recommended 
examples.  

o USFWS (The word “Credit:” will automatically be appended), or 

o photog name/ USFWS (The word “Credit:” will automatically be appended), or 

o © Dan McGarry (Use copyright symbol and photographer’s name). 

8. Click the Save button ( ). The image is added to the Library. 
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Restoring Content from its History  
Reference: “Content” chapter in Ektron CMS400.NET Reference Manual. 

A complete history is maintained for content in the CMS. You can view older versions, compare the current published version with older 

versions and restore versions of content as desired. 

Restoring in the Workarea 

 

1. In the Workarea, navigate to the Fish Springs > Section Configurations folder. 

2. Click on the content entitled Visit – Plan Your Visit (content ID 705).  

3. Click the History button ( ). The Content History window opens. 

 

4. Select a version to view the differences between the most recent version and an earlier version. The whole number 
indicates a published version while a decimal number indicate any content that has been checked in. 

Note: The compare radio buttons are for comparing the analytics between versions. 

5. Click the View Diff ( ) button to view the differences between the live version and that historical version. When 
finished, close this window. 

6. Restore the selected historical version by clicking on the Restore button ( ). The Content History window will close and 
you will return to the Workarea window.  

Note: The content is in a “Staged” state – that is, it is “Checked In” but not published. 

7. Click the View Stage button ( ) to see the historical version you’ve restored.  

8. To make the restored version appear on your web page, click the Edit button ( ), make any changes you like, then 
publish the changes. 
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Restoring in a Web Browser 
1. In a browser, navigate to the folder containing the content you wish to restore..  

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Scroll over the silver access point and select View History from the menu 

3. Follow steps from the previous exercise: Restoring in the Workarea. 

4.  Purging the History 

Note to instructor: Fresh installs of CMS400 Developer sites do not have content history as they are purged before shipping the 

product. 

1. Click on the Test Folder. 

2. Choose menu View > Folder Properties. 

3. Click on the Purge History button on the tool bar. ( ) 

4. Set the today’s date to purge. Uncheck the options  for Recursive Purge or Purge versions marked as published, as shown 
below:

 

5. Click on the Purge History button to start the purge process ( ).  

When the purge is complete, only the published versions of the content will be left in the history. If you want to remove all older 

versions of content, check the Purge versions marked as published box before purging. 
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Copying / Moving Content 
Reference: “Content” chapter in Ektron CMS400.NET Reference Manual. 

Users can copy or move content from one folder to another folder, but they cannot copy or move an entire folder.  

Note: To achieve something like moving a folder, a user must create a new folder with the same settings as the original one, then 

move all the content from the original folder to the new folder.  

If the original folder uses a SmartForm, make sure the destination folder uses the same Smart. 

 

Copying Content 
1. Navigate to the Fish Springs NWRS > Your refuge > Alert folder  

2. Click on HTML Content next to the Alert content 

3. Right Click and select Copy.  

 

4. Browse to where you want to paste the copied content  

5. Right click and select Paste Content.  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click ALL to accept the change. 
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 Moving Content 
1. Create a new folder under Test Folder and call it Test 2. 

2. Browse to the Test Folder. 

3. Click on HTML Content that needs to be moved in order to highlight it. 

4. Right Click and select Cut.  

5. Browse to Test 2 

6. Right click and select Paste Content. 

7. Click Continue to finish moving the content. 

 
 

  



 

307 | P a g e  

 

The Library 

Adding a Hyperlink 
1. In the Library tab, choose your asset folder. 

2. From the drop down list, select Hyperlinks. 

3. Click the Add button ( ). 

4. Enter a title for the hyperlink, which will become the link text. (Example: “Click here to visit Ektron”). 

5. Enter the URL for the link. (Example: http://www.ektron.com) 

6. Add a Description. 

7. Click the Save button ( ). The hyperlink is added to the Library. 

 

Adding a File 
1. In the Library tab, choose your asset folder. 

2. From the drop down list, select File. 

3. Click the Add button ( ). 

4. Enter a title of the file  

5. Click Browse to select the file 

6. Enter a Description. 

7. Click the Save button ( ). The file is added to the Library. 

Images  
Inserting an Image 

1. Click inside the left cell of the table. 

2. Click the Library button ( ). 

3. From the dropdown list, select Images.  

 

4. Browse to the folder that contains the image you want to add. 
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5. Click on an image. 

6. Click the Insert button ( ) to insert into the content. The picture will be inserted.  

7. You can modify the image size, position, border and spacing by right clicking and choosing Set Image Properties.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. Once you are satisfied with the settings, click OK and the picture properties will be changed. 
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Adding Images to the Library 
Reference: “Library Folder” chapter in Ektron CMS400.NET Reference Manual. 

 

Adding Images and Hyperlinks to the CMS Library makes them readily available for use when creating or editing 
content. 
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Adding an Image 
1. In the Workarea select the Library tab. 

2. Navigate to the folder Home. 

3. From the drop down list, select Images. 

4. Click the Add button ( ).The Add Library Item window appears. 

a.  

5. Click the Browse button to browse your local or network drives to locate an image. 

6. Enter a title for the image and add a Description if needed. 

7. Click the Save button ( ). The image is added to the Library. 

Editing Image Properties 
1. In the Library, click the image you want to edit.  

2. Click the Edit button (See figure.) 

3. Edit the title or description of the image. 

4. Click Update ( ). 
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Overwriting an Image 
1. Click the image you want to overwrite. 

2. Click the Overwrite button ( ). 

3. Click Browse to select the replacement image. 

4. Click Update ( ). 

5. Click OK in the popup box to overwrite the old image with the new one. 

Deleting an Image 
1. Click the image you want to delete 

 

 

 

 

 

 

 

 

 

2. Click the Delete button ( ). 

3. If you want to remove the file from the CMS server, check the Remove from the server box, then click the 
Delete button again. If you only want to remove the image from the folder, leave the box unchecked and 
click the Delete button again. 

4. Click OK in the popup message box to delete the image. 
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Uploading and Inserting an Image 

1. Position the cursor where you would like to insert an image and click the Library button ( ). 

2. Navigate to the folder you would like to add the image to. 

3. Click the Add Library button ( ) to add a new image to the library. 

 

4. Click the Browse button. This opens a standard browser window for browsing local or network drives for 
an image. Select an image and click Open.  

 

5. Enter a title for the image. 

6. Click the Add Library button ( ) again to add the new image to the Library. 

7. Click OK. The image you selected is added to the content. 
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8. Click the Save button ( ) again to temporarily save your work. 

 

 

 

  


