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Unit 7 
Events - How to Create & 

Edit 
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Overview 
The Events Calendar is used to display events on an individual, upcoming or daily basis. Upcoming events display on the calendar landing 
page. When a day is clicked on the calendar, the list of all events for that date are displayed, if there is only one event for that day then the 
event details page is opened and displayed. 
 
It is very important that you understand how the events have been structured in Ektron so you can manage it correctly. To better 
understand this, log into Ektron and navigate to your refuge Events folder and familiarize with the structure and what type of content items 
reside where. Workarea > Content Tab > Your Refuge folder > Sections > Events folder. 

 Events are stored in TWO Folders under your Events section folder. 
o Calendar Items folder – This is the actual Refuge calendar that you see in right column of every events page.  
o Event Details folder – This folder contains the detailed Event content you created using the Event SmartForm. This is 

the actual content your visitors will see. 

 The Calendar Items folder (Refuge Calendar) is the one that manages the year, month, date, time and reoccurrence of events. 
When creating an event here, you only need to fill out the Event Title and associate it with the Event Detail content using the 
EventContent metadata. Simply, the event created here is a container and pulls in the full details of the event from event content 
residing in the Event Details folder. 

 EventContent metadata is used to connect the event created in the Event Details folder to the event that was created in the 
Calendar Items folder. You cannot create an event in the Calendar Items folder without choosing the associated event details 
content using this metadata. The system will not allow you to publish and inform you that you need to fill out the EventCalendar 
metadata. 

 

When creating an event you must create it in the following order: 

1. First, create the detailed Event in the Event Details folder using the Event SmartForm. 
2. Create event in the Calendar Items Folder. Associate the Event SmartForm content you created in the Event Details folder with 

the Calendar Item event using the EventContent metadata in the Metadata Tab. 

NOTE: Use the Creating an Event cheat sheet (below) as quick reference guide.  

NOTE: The events created here are separate from the Featured Event on the Homepage. The Homepage Featured Events are created using 
the Homepage Featured Events SmartForm and resides in the Your Refuge > Home > Featured Events folder.  
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Content Definition: This template accommodates the unique content requirements for events, such as dates, locations, 

fees, and other incidental information.  

Section Use: Events  

Views: There are three event views (show below) that are available by design. They are: 

 Upcoming Events – Displays when you click Visit > Event Calendar menu.  
o By default 3 upcoming events are displayed, this can be adjusted by editing the NWRS_Events widget.  
o The events are pulled from the refuge Calendar Items folder. 

 Event Day – Displays when you click on a date in the mini calendar located in right column of the homepage and Upcoming 
Events page. 

o Displays ALL the events for the selected day.  
o If more than one event resides in a day, it is displayed in list format like the Upcoming Pages folder. 
o If there is only one event for that day, the detailed event page will be shown. 

 Events Detail – Displays the full event details. Shown when clicking on Learn More in Upcoming Events and Event Day page 
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Create an Event Cheat Sheet 
Use this Event Cheat Sheet as a quick reference guide to assist you to build out events on daily basis.  

Create the Detailed Event Content  
(Detailed instruction: Unit 7 Create Event Detail section) 

1. Log into Ektron and open Workarea > Content Tab. 
2. Navigate to Your Refuge > Sections > Events > Event Details folder. 
3. From the toolbar, select New > Event. 
4. The Event SmartForm will open. 
5. Fill in the following fields: 

a. Title – Required 
b. Dates - Required 
c. Image - Required  
d. Short Description – Optional 
e. Body Text – Required. You must add approximately 110 words into the body text otherwise the detail 

section will move up and wrap around the image giving less than optimal results. 
f. Details Title – Optional 
g. Details Information - Optional  
h. Details Incidental Italicized Text – Optional 

6. Click Save and the Preview option will display on the content toolbar. Preview option does not display on initial 
create until the first Save has occurred. 

7. Click Preview and a new window will open displaying the page in Preview mode. Check to see that your page is 
displaying correctly. Go back to the Event SmartForm you are working on and make changes as necessary, clicking 
Preview to see the changes. 

8. Click Publish when page is complete. 

Create Calendar Item  
(Detailed instructions: Unit 7 Create Calendar Items Event section) 

1. Navigate to Your Refuge > Sections > Events > Calendar Items folder. 
2. From the toolbar, select New > Add Calendar Event. 
3. The Edit Appointment window will appear in Event view with Event Tab highlighted. 
4. Fill the following Event fields: 

a. Title – Match the title with the detailed event content you created above. 
b. All Day – Disable this option if you want to specify a date and time range. Only Start time option is 

displayed if this option is enabled. 

c. Start Time & End Time – click on the respective Start/End icon ( ) and Time icon ( ) to set the date 
range and time range. 

5. Click the Recurrence Tab if you want to set this event to be recurring.  
6. Enable Recurrence and recurrence options will appear. Set the recurrence options that you want. 
7. Click on the Metadata Tab. 
8. Click Edit for EventContent metadata. The EventContent metadata is used to associate this Calendar Item with 

Detailed Event content you created above. This Calendar Item you are creating will display on the mini calendar 
located in the right column of the page, when visitors click on that date they will see the Event Detail content you 
created above. This is accomplished using the EventContent metadata. 

9. Library window will appear in Quicklinks mode. 
10. Navigate to Your Refuge > Sections > Events > Event Details folder. 
11. Select and Highlight the detailed event content you created above. T 

12. Click on Insert icon (  ) and the detailed event content will appear in your EventContent field.  

13. If you selected an incorrect detailed event content, Click on the Clear icon ( ) and repeat steps 16-20. 
14. Click Save when finished.  
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Common Questions and Answers 
 

How do I edit the event content? 

1. Navigate to Your Refuge > Sections > Events > Event Details folder,  
2. Click on the Event Detail content you want to edit and select Edit. 

Note: You edit the Event Details content and not the Calendar Item because it is the Event Detail that your visitors see. See 
Unit 7 Overview section for more details. 

 

How do edit my Calendar Item? 

1. Navigate to Your Refuge > Sections > Events > Calendar Items folder,  
2. Navigate to the date that contains your event from the displayed calendar and double click on the event you want to 

edit. If there are multiple events on that date, click the More link and then select your event by double clicking on it. 
3. If the there are no previous recurrences, the Calendar Item will automatically open in edit mode. 
4. If there are existing recurrences a pop up window will open asking you if you want to Edit the Series or Edit the 

Occurrence pick the relevant option and the Calendar Item will appear in edit mode. 

 

How do I change the Event Date(s) shown on the Event Details page? 

See “How do I edit the event content above” and then update the Date(s) field with correct dates. 

 

My event is on the wrong date in the mini calendar, how do I change the date? 

1. Edit your Calendar Item as shown in step 1-4 of How do I edit my Calendar Item.  
2. Change Start & End Time (located bottom left corner) by clicking on the respective icon. 

NOTE: You cannot specify Date or Time range if All Day is enabled. 
3. Click Save when complete 

 

How do I add, remove or edit my event recurrence? 

1. Navigate to Your Refuge > Sections > Events > Calendar Items folder,  
2. Navigate to the date that contains your event from the displayed calendar and double click on the event you want to 

edit. If there are multiple events on that date, click the More link and then select your event by double clicking on it. 
3. If the there are no previous recurrences, the Calendar Item will automatically open in edit mode. 
4. If there are existing recurrences a pop up window will open asking you if you want to Edit the Series or Edit the 

Occurrence pick the relevant option and the Calendar Item will appear in edit mode. 
5. Click the Recurrence Tab 

a. To Add a recurrence, enable the Recurrence checkbox and then set the recurrence options. 
b. To Remove a recurrence, disable the Recurrence checkbox. 
c. To edit a recurrence, change the recurrence options available to you. 

6. Click Save. 

 

I associated the wrong Event Detail with my Calendar Item, how do I correct this? 

1. Edit your Calendar Item as shown in step 1-4 of How do I edit my Calendar Item.  
2. Click on the Metadata Tab. 
3. Click on the Clear button for the EventContent metadata. 
4. Click on Edit button for the EventContent metadata. 
5. From the Library window, select the correct Event Detail content in the Event Details folder so it appears in the 

lower right frame of the Library window. 
6. Click on the Save icon and the selected Event Detail content link will be inserted into the EventContent metadata 

field. 
7. Click Save. 
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Create Event Detail 
Exercise 7-1 Event Detail 

In this exercise we will create an events detail page such as the one shown in Figure 7-1. 

 
 

Figure 7-1 
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Event Detail SmartForm Image 

  
 

 
Go to Your Refuge > Sections >Events > Events Details folder. Then select  New > Event SmartForm from the menu. 

A. Fill out the title section, this will be the name of the page and the title for the top heading. 

B. Fill out the Dates which this event will take place. 

C. Image:  

1. Click the Image button (             ) 

2. Click the Select Picture button (        ) 

3. Double click on the desired image. 

To remove an image from your page use the Menu ( ) button. 

D. Fill out a Short Description, depending on length this text will wrap around the image. 

E. Fill out the Body Text 

F. Fill out the Detail Title 

G. Fill out the Details Information 

H. Fill out the Detail Incidental Italicized Text 

I. Click the Alias Tab and create an Manual Alias 

J. Publish 
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Create Calendar Items Event 
Content Definition: This template accommodates the unique content requirements for events, such as dates, locations, 

fees, and other incidental information.  

Section Use: Events 

Exercise 7-2 Create a new Calendar Event 

In this exercise we will create a new calendar event. 
1. Navigate to  Sections > Events > Calendar Item 
2. Choose New > Add Calendar Event  from the menu. 

 

 
 

Creating a new Calendar Event to appear on the Calendar 

 
 

A. Title: Enter a Title for your Event 

B. Location: Enter the location of your Event 

C. Description: Enter the description for the Event 
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Exercise: 7-3 Calendar Event Time and Date 
In this exercise we will set the date and time for your calendar event. 

 
A. Date: Click the calendar button(      )and select the appropriate date from the popup display for the start date. Repeat 

this step for the End Date. 

       
 
 
 
 
 
 
 
 
 
 

B. Time: Click the time button(      ) and select the appropriate Start Time from the popup display. Repeat this step for the 

End Time. 
  
 
 

 
 

 

C. Select All Day Event if event has no timeframe. 
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Exercise: 7-4 Setting a Recurrence for a Calendar Event 
In this exercise we will set the recurrence for a repeating event. 

 
A. Select the Recurrence tab. 

B. Check the  Recurrence Box 

C.  Fill out the fields detailing the timing and frequency of recurrence for the Calendar Item. 

D. Click Save. 
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Exercise: 7-5 Associate an Event Detail with a Calendar Event 
In this exercise we will associate an event detail with a calendar event. If this is the only event occurring on this date this will cause the 
event detail to open when you click on that date in the calendar. If there are several events occurring on the same date there will be a list 

with a view detail link. Clicking the view detail link will open the event detail. 

 
A. Click the Metadata tab. 

B. Click Edit  

C. In Popup window navigate to your Region folder then to Your Refuge > Sections > Events > Event Details 
1. Locate the Content to be added to the Calendar Item 
2. Double click the desired Content  

3. Click the save button(  ) in the Reorder and Finalize Selections window 

D. Click Save. 
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Upcoming Events Page 
The Upcoming Events page has already been created for you. Create a new Upcoming Events page only if you deleted the original by 
accident. Skip to Exercise 7-7 Step 4 (Adding or Editing an NWRS_Events Widget) to update the Upcoming Events properties. For example: 
point to the correct refuge event calendar, specify how many events to be displayed.  

Exercise: 7-6 Creating Events PageBuilder Page 
In this exercise we will create a PageBuilder page for you to add the Events Widget to. 

 

1. To create an Upcoming Event page navigate to Sections > Events. 

 
2. Choose New > Page Layout 

 
 
 
 
 
 
 
 
 
 
 
 
 

3. Add New Page: 
A. Choose three column layout this will generate a three column PageBuilder page. 
B. Click Next  
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PageBuilder Image: 

 
 

4. Title, Aliasing, and Taxonomy 

A. Enter a page title into the Page Title Field. This is the name of your content block. 

B. The alias field is automatically populated when you enter in a page title. You are able to change the alias to a different 
name if you would like a different alias. 

C. Click Next 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Metadata 

A. Enter Keywords in the Keywords field and click the Add button (           ). Keywords are used for search engine 
optimization. 

B. Enter a description in the description field. Used to create a description of your page to allow search engines to locate 
your content. 
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C. Click Finish   

 
 

 

 

6. Click OK. 
 
 
We will complete the page for upcoming events in exercise 7-7. 
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Exercise: 7-7 Adding/Editing an NWRS Events Widget.  
The following instruction shows you how to add and edit the NWRS Events Widget. Skip to Step 4 if you want to edit the widget. 

 

1. Click the arrow in the top left corner of the page to open the page builder fly out menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Click the arrows in the middle of the menu bar to open the widget tray. 
 
 
 
 

 

 

3. Click and hold the NWRS_Events widget, Drag it into the blue content block. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Place your mouse over the first white box (located in the upper right corner of the widget) until a pencil icon (Edit) appears and 
Click on it.   
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5. The NWRS Events edit window will appear.  

 
6. Enter in the Calendar ID in the Events Calendar ID field. You can find the refuge Calendar ID by: 

a. Go to Workarea > Content Tab > Your Refuge > Sections > Events > Calendar Items folder. Select the Calendar Items 
folder. 

b. Go to View -> Properties and in the Properties tab you will see the Calendar ID 

 
7. In the No. of Upcoming Events field, add the number of events that you wanted listed on that page by default. 
8. Click Save. 
9. Select File > Publish in the top left corner. 

 
NOTE: If there were no events created as show in exercises 7-1 through 7-5 that are upcoming from the current date there will not be 
any “Upcoming Events” to list in this widget! 

 

Homepage Featured Events 
Homepage Featured Events have no association with your refuge Event Calendar, they are two separate items, and are 
created independent of each other. For instructions on how to create Homepage Featured Events go to Exercise 10-1 
Creating/Editing Featured Events. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



  

122 | P a g e  
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Unit 8 
Multimedia - How to 

Create & Edit 
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Overview 
The Multimedia section has been designed to highlight your refuge site using the rich media available to you, specifically 
images, audio, video and web cam. The Multimedia section is broken into three sections: 

 Multimedia Landing page – this page provides you with creating a specific subject you would like to highlight for 
your refuge and also lists all the available media types that site visitors can review by providing them with links to 
the specific media type listing page (Multimedia Listing Page). You have the ability to only display those media types 
that you have and not add those you do not. For example, Photo and Video media types are the most popular for 
most refuge sites. 

 Multimedia Listing page – this page lists all the available media for the specific media type. If you have media for all 
the media types you would end up with a Photo Listing page, Audio Listing page, Video Listing page and Web Cam 
Listing page.  

 Gallery Page – this page is built for each specific subject and options to view/hear the available media for this 
subject is presented to the site visitor. 

 Browse Multimedia by Subject – this is a Three Column List SmartForm content list that displays on the bottom of 
all Multimedia pages. You do not have to add it to pages; it is automatically added for you. You only need to update 
this list content for your site. 

The Multimedia Landing page, Video Listing page, and two Galleries example pages have been provided for each refuge site. 
You will be required to build out Gallery pages and Multimedia Listing pages (for those media types you will be supporting) 
and customize the Multimedia Landing page for your refuge site. Follow this procedure when customizing your Multimedia 
section: 

1. Gather all the media and contents that you want for your Multimedia section. 
2. Create a Gallery page (in Gallery folder) for each subject (for example: Rocky Mountain Elk) that will reside in the 

Multimedia section. Specific instructions can be found at Unit 8: Multimedia Gallery Page. 
3. Update the Browse Multimedia Section content (in Multimedia folder) with Gallery pages you created. Specific 

instructions can be found at Unit 14: Create/Edit a List using Three Column List SmartForm. 
4. Create a Multimedia Listing page (in Multimedia folder) for each media type you will be supporting. Specific 

instructions can be found at Unit 8: Multimedia Listing Page. 
5. Modify the Multimedia Landing page located in the Multimedia folder. Specific instructions can be found at Unit 8: 

Multimedia Landing Page. 

 

An alternative method to managing your Multimedia files is through using services like Flickr and YouTube to host your 
images and videos and then use PageBuilder page with Flickr and YouTube Video widgets to displays these media. 

 

Content Definition: Multimedia (persistent link) – goes to the multimedia promo page of the refuge site you are on, even if 

it only has a couple of photos or one podcast. It can link to other FWS multimedia sites such as http://www.fws.gov/digitalmedia.  

Section Use: Multimedia Page 
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Exercises 
Multimedia Gallery Page 
In this section you will learn to create a Multimedia Gallery. A Multimedia Gallery is used for displaying a collection of multimedia items, for 
example Photos, Videos, Web Cameras and Audios. Each refuge is required to create a gallery with a minimum of one Main Photo and at 
least one Multimedia type, Ex. Video, Photo, Web Camera, or Audio files. The Gallery is typically used with the Multimedia Landing Page 
and Multimedia Listing Page. Optional: You may also add a Three column list with Extra Photos and Multimedia types. 

 

 
 

Content Definition: Multimedia (persistent link) goes to the multimedia page of the refuge site you are on. It can have links 

to regional and/or refuge specific social media sites, such as http://www.fws.gov/digitalmedia. It can have links to social media sites, such 
as Twitter, Facebook, YouTube, and Flickr (even though these are technically not multimedia.) Regional and/or refuge-specific podcasts and 
RSS feeds will also be located here. 

 

Multimedia Gallery has a free form text editor. A pre-set list of type styles will be available to web authors which include:  

1. page title 

2. image 

3. description 

4. photo and thumbnails 

5. audios 

6. videos  
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7. web cameras  

 

 

Section Use: Multimedia 
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Exercise: 8-1 Creating a Gallery SmartForm 
In this exercise we will create a new Gallery SmartForm. 

NOTE: To organize the various media types that will be uploaded to your refuge, create sub-folders under the Galleries folder for each 
media type. For example: Photo folder, Audio folder and Video Folder. Instructions can found in Appendix B: Creating & Editing Folders. 
Ensure you disable Require Smart Forms and remove any Smart Forms assigned to these media folders, failure to do so will prevent you 
from uploading files to these folders. 

 

1. Navigate to Sections > Multimedia > Galleries folder. 

2. Choose New > Gallery SmartForm from the menu. 
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Exercise: 8-2 Adding content to the Gallery. 
In this exercise we will add a Title, Image, and description to your new Gallery. See Figure 8-2 for an example.  
 

  
 

Adding Content SmartForm Image  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Go to Multimedia > Galleries > New Gallery. 

 

A. Title: Enter a title in the title field in the above SmartForm. 

B. Image: 

1. To insert a photo use the Image Manager (  ) button to pick your image from the Library images.  

2. The Library window will appear in the images mode in the same folder as where the gallery is being built. Navigate to 
and select the image you would like to add.. For example (Library > NWRS > Your Refuge > Sections > X) 

 

C. Description: Enter in content that you wish to display.  
 
NOTE: It is recommended that all images that will have an accompanying Title and Description should have width of 712 pixels.  If the 
image is smaller than 712 pixels, the translucent area where the Title and Description texts displays on will extend past the image resulting 
in an unprofessional looking page.  
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Exercise: 8-3 Adding your Multimedia content. 
In this exercise we will learn how to add multimedia content. For example: Photos, Audio, Video, and Web Cams. 
 

 
A. Multimedia: When creating this page at least one-multimedia type is required but multiple are optional. 

 
Adding Photos 

1. Click on Add Photo ( ) and Add Thumbnail ( ) icons to display the respective Image Manger ( ). 

2. Click the Photo Image Manager (  ) button and the Library window will appear in images mode. 
3. Navigate to the Library folder that contains the image to be selected. For example:  Library > NWRS > Your Refuge > 

Sections > Multimedia >  Galleries.  
4. Select the image and insert it by either double clicking on the image or highlighting the image and clicking on the Insert 

( ) button. 
5. Repeat steps 2-4 for the Thumbnail. Keep the Thumbnail size to 70x60 pixels, if the height or width is smaller or larger 

the photo selector slide show will not display properly. 
 

6. To add a Photo caption, enter content into the provided text box.  

7. To add additional photo Click the Photo ( ) button. 

8. To remove a photo from the page use the Menu ( ) button. 
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Adding Audios and Videos 
Refer to Unit 14: Uploading Files section on instructions on uploading audio/video files to your refuge site.  
Uploading audio/video files to the Library is the preferred and recommended method.  

1. Click on the Link Manager ( ) in the Audios\Videos section and the Link Manager window will open. 

2. Click the URL ( ) button and Library window will appear. 
3. In the Library window select either option from the first dropdown list based on where you uploaded the audio file 

 Select File, if you uploaded the audio file into the Library. Recommended 

 Select Quicklinks, if you uploaded the audio file using the Document Management System (DMS). 
4. Navigate to the folder that contains your audio\video file. Skip to Step 7 if you have to upload your Audio\Video file. 
5. Select the Audio\Video file and Insert. Skip to Step 11. 
6. If your Audio\Video file is not in the Library and you want to upload it. Perform steps 

7. Click on the Add Library ( )  icon and the Upload/Insert file window will appear. 

 
8. Click Choose File and select the file you wish to upload from file explorer window and click Open. 
9. Add the Title for the file. 

10. Click on the Add Library ( ) icon and the file will be uploaded to the selected folder in the Library. 
11. Ensure the Link Text and Tooltip fields are properly filled out in the Link Manager and Click Ok. 

 
12. The Audio\Video file is inserted into the Galleries SmartForm. 
13. To add additional Audio or Video files click on the respective Add icon and repeat the above steps, 
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Adding Web Cam 

The Web Cam is a video feed option. Ensure you have the video feed URL before proceeding. 

1. Click on the Link Manager in the Web Cam section and the Link Manager window will open.  

2. Enter in the URL of the Web Cam feed in the URL field. 

3. To add additional Web Cam feeds, Click on the Web Cam add icon. 

4. Publish the Galleries SmartForm. 
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Multimedia Listing Page 

The Multimedia Listing Page is provided for each Refuge site and the only requirement for the CMS Editors is for them to build out the 
Galleries and each listing page will be updated automatically from Galleries. There are four Multimedia Listing Page types: 

 Photo 

 Audio 

 Video 

 Web Cam 

Sample Galleries have been created which will generate some Multimedia Listing Page types but not all. You will need to add Galleries 
that are relevant to your Refuge and add the Media types that you have. Instruction for creating Galleries can be found in Unit 8, in the  
NWRS Multimedia Gallery  section.  

 

This section covers how to create a Multimedia Listing Page in case you delete the one that is provided. A Multimedia Listing Page is 
used to list a select group of multimedia from your Galleries folder, for example Photos, Audios, Videos and Web Cams. The listing is 
automatically created by the NWRS_Media Listing Widget from the Galleries that you create. There is also an optional Browse 
Multimedia by Subject that is Three-column list which automatically displays if the Multimedia by Subject has been created and resides 
in the Multimedia folder. 

 

 
 

Content Definition: The web author will need to produce the Multimedia Gallery in the Galleries folder.  

Multimedia Listing Page has a pre-set list of widgets that will be available to web authors which includes:  

NWRS_Media Listing Widget. 

 

Special Notes: N/A  

 

Section Use: Multimedia. 
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Exercise: 8-4 Create/Edit the Multimedia Listing Page 

In this exercise we will create a Multimedia Listing Page using the Three Column PageBuilder wireframe template and the 
NWRS_Media Listing widget.  

 

1. To edit the Multimedia Listing page. Navigate to Your Refuge > Section > Multimedia folder and edit the page. Refer 
to Unit 14: Working with Content - Managing Content & Page - Edit PageBuilder Page for detailed instructions. Skip 
to Exercise: 8-5 Add/Edit the NWRS_Media Listing Widget section below. 
 

2. To create a new Multimedia Listing page navigate to Sections > Multimedia. 
 

 
3. Choose New > Page Layout 
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5. Add New Page: 

A. Choose three column layout this will generate a three column PageBuilder page. 

B. Click Next  
 

6.  
 

7. Title, Aliasing, and Taxonomy 

A. Enter a page title into the Page Title Field. This is the name of your content block. 

B. The alias field is automatically populated when you enter in a page title. You are able to change the alias to a different 
name if you would like a different alias. 

C. Click Next 
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9. Metadata – Refer to Unit 14: Managing Content/Page Properties - Adding Metadata to add the Metadata. Click Finish when 
Metadata is completed. 

 

10. Click OK, you will then be brought to a rendered three-column PageBuilder template.  
 
 
 
 
 
 
 
 
 
 
 
 
 



 

137 | P a g e  

 

Exercise: 8-5 Add/Edit the NWRS_Media Listing Widget 
In this exercise we will be adding the NWRS_Multimedia Listing widget to the PageBuilder page in order to display a 
multimedia list on out page. Skip to Step 4 to edit the NWRS_Media Listing widget. 

1. Click the arrow in the top left corner of the page to open the PageBuilder fly out menu. This will allow you to access your 
widget tray. 

 
 
 
 
 
 
 
 
 
 
 

2. Click the arrows in the middle of the menu bar to drop down your widget tray 
 
 
 
 
 
 
 
 

3. Locate the NWRS Media Listing Widget in the widget tray. Drag and drop the widget into the center of the blue box.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Hover over the first white square and a pencil icon will appear, click on it and the Editing Widget window will appear. 
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5. Click on the folder tab and locate your gallery folder through the menu structure. 

 
6. Navigate to Sections > Multimedia > Galleries folder. 

 

7. Click on your properties tab, and select what type of media you are listing. For example:  Videos, Audios, Photos, or Web 
Cameras 

 

  
 

 

8. Click Save. 
 
 
 
Here is a view of your completed Multimedia List on the page. 
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Multimedia Landing Page 
The Multimedia landing page has already been created for your refuge and does not need to be created. Modify the existing landing page 
with your refuge content. This Multimedia section is provided for you in case you accidentally delete the existing one. 

 

In this section you will learn how to create a Multimedia Landing Page. A Multimedia Landing Page is an internal landing page that allows 
you to display multiple items in a list to highlight multimedia content. When creating a Multimedia Landing Page you will need to display at 
least one multimedia section. You are also able to add an optional side menu to your page. The Introduction Link, Social Media and Three 
Column list are optional items for your Multimedia Landing Page and must be created prior to completing this page. 

 

 
 

Content Definition:  Multimedia (persistent link) goes to the multimedia page of the refuge site you are on, even if it only 

has a couple of photos or one podcast. 

 



 

141 | P a g e  

 

Multimedia Landing pages have a free form text editor. A pre-set list of type styles will be available to web authors which includes:  

1. page title 

2. image 

3. description 

4. introductory link  

5. multimedia list 

 

Web authors will have control over number, size, justification (left or right), and the placement of photographs on the page. 

 

Special Notes:  N/A 

 

Section Use: Multimedia 
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Exercise 8-6: Editing/Creating a Multimedia Landing Page 

 

1. To Create a Multimedia Landing page: Navigate to Sections > Multimedia. Skip to Step 3 for instructions on editing existing 
Multimedia Landing Page. 

 
 

2. Select New > Multimedia Landing Page. 

 
  

3. To Edit an existing Multimedia Landing Page: Navigate to > Your Refuge > Sections > Multimedia folder.  

 
 

4. Edit the Multimedia Landing Page SmartForm content. Typically this content is titled Multimedia. 
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Exercise 8-7: Adding content into the SmartForm.  

In this exercise we will add a Title, Image, Description, Gallery Link, and Social Media Links to our page.  

(See Figure 8-5) 

 
 

 

Figure 8-5 
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Adding/Editing Page Introduction - Image 1 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

A. Title: Enter or modify the title in the Title Field. 

B. Image: 
1. Click Select Picture (          ) button.  
2. The corresponding folder in the Library where you have uploaded your image will come up. Sections > X 

3. To remove the image use the Editor ( ) button and you will  
be prompted by a menu that will allow you to remove the image. 

 

C. Description: Enter or modify the description in the description field. 

 

 

Adding Content SmartForm - Image 2 
 

 

 

 

 

 

 

 

D. Introduction link: 
1. Click the PageIntroLink (                              ) button. Skip this step if link exists. 
2. Click the Link (         ) button.  

3. Manually enter a URL or click the URL ( ) button and navigate to your content. Sections > Multimedia > 
Galleries. Make sure Quicklinks is highlighted. 

4. Select the content that you wish to display. 
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Exercise 8-8: Adding or Modifying the Multimedia List. 
In this exercise we will add or modify content to the Multimedia List which will be displayed on the page as seen in  

Figure 8-6.  

  

Figure 8-6 
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Adding Photo, Audio, Video, or Web Cam to the Multimedia List 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

F. Go to the Multimedia Listing section of the Multimedia Landing Page SmartForm. 

G. Title: Enter a title in the Title Field. 

H.  Image:  Insert or edit the image that will be displayed in the list. Image size should be 150x118 pixels. 

1. Click on the Image Selector ( ). 

2. Image properties window will open. 

3. To select a new image, Click the Image Src button. 

4. Library window will open in images mode. 

5. Navigate to the image to be selected. 

6. Highlight and Click Insert. 

7. The Image Src field will display the path to the image. 

8. Update the Image Alt Text. The Image Alt Text will appear as tooltip for the image. 

9. Click OK and the image properties window will close and the image will appear in the image column. 

I. Description: Enter a description in this field. 

J. Link: This field is used to classify your content. Choose one of the options below. 

 Audio  

 Photos  

 Videos 

 Web Cams  

To manipulate your Multimedia List use the Menu (  ) button.  

 

 

 

 

 

 

K. Add additional Multimedia List items by repeating Steps F – J. 

L. Click the Publish button for the Multimedia Landing Page SmartForm. 

 
 

 

 

 

 

 



 

147 | P a g e  

 

Exercise 8-9: Browse Multimedia by Subject 
The Browse by Subject section displays on each published Gallery, Multimedia Landing Page or Multimedia Listing Page and automatically 
pulls the list from the Three Column List SmartForm content that resides in the Refuge Multimedia folder. Changes made in the Three 
Column List SmartForm content will automatically update the Browse by Subject sections on every page. 
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1. Navigate to Your Refuge > Sections > Multimedia folder.  

2. Select New > Three Column List SmartForm. 

3. Add individual items. 

 

Three Column List SmartForm  

 
 

A. List Title: Enter in a title for your list.  

B. Editor ( ) Button: Located in the upper left hand corner will allow you to move around or remove content blocks. 

 

 

 

 

 

 

 

 

C. Links: add a link to the items page.  

1. To add a link click on the Link ( ) button this will open up your link manager. 

2. Next click on the URL ( ) Button.  

3. That will lead into the library, make sure you are in quicklinks. 

4. Navigate to Library > NWRS > Your Refuge > Sections > X 

5. Make sure your Quicklinks are activated. 

6. Double click on your link and then hit OK on the Link Manager Screen. 

 

D. Additional Text: Room for some additional information.  

E. File Size: Optional and will allow you to enter in the size of your file that you might display. 

F. Column: This allows you to choose the column the item will display in.  
 

 
 

 

 

 



 

149 | P a g e  

 

G. To add a new Column Item use Click the Column Item ( ) button. 

 
 

4. Click the Publish ( ) button to publish the Browse by Subject content. 
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Alternative Multimedia Page Options 
Use this section if you want to build out your Multimedia section using media services like Flickr and YouTube. 
 

NOTE: It is recommended that you create a sub-folders under Your Refuge > Sections > Multimedia folder to hold your Flickr 
and YouTube pages. For example: 
 

 Multimedia 
o Hosted Media Gallery 

 
Instructions on creating folders can be found at Appendix B - Creating & Editing Folders. Ensure you configure the Smart Form folder 
property as such: 

 Disable Inherit Parent Configuration 

 Disable Require Smart Forms 

 Add Promo Page Smart Form 

 Remove Multimedia Landing Page Smart Form 

 Make Blank HTML the default. 
 

Create Photo Gallery Page using Flickr 
Following instructions show you how to create a Photo Gallery page using PageBuilder and Flickr widget. The photos are 
hosted on Flickr.com so you will need a Flickr account to manage your photos there. The Flickr widget simply acts as a display 
mechanism for the photos residing on Flickr. 

Exercise: 8-10 Create/Edit the Photo Gallery Page 

 

1. To edit the Flickr Photo Gallery Page. Navigate to Your Refuge > Section > Multimedia > Folder X (folder x denotes 

folder you created to host this page). Refer to Unit 14: Working with Content - Managing Content & Page - Edit 
PageBuilder Page for detailed instructions on how to edit the page. Skip to Exercise: 8-11 Add/Edit the Flickr Widget 
section below. 

2. To create a new page navigate to Sections > Multimedia > Folder X (folder x denotes folder you created to host this page). 
 

3. Choose New > Page Layout 
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4. Add New Page: 

A. Choose two or three column layout this will generate a two or three column PageBuilder page. 

B. Click Next  

  
 

5. Title, Aliasing, and Taxonomy 

A. Enter a page title into the Page Title Field. This is the name of your content block. 

B. The alias field is automatically populated when you enter in a page title. Modify this alias so it follows the URL Aliasing 
Standards defined in Unite 3: URL Aliasing Standards. 

C. Click Next 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

6. Fill out the Metadata fields using Unit 14: Adding Metadata section as reference. 

 

7. Click OK, you will then be brought to a rendered two or three-column PageBuilder template.  
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Exercise: 8-11 Add/Edit the Flickr Widget 
7. Click the arrow in the top left corner of the page to open the PageBuilder fly out menu. This will allow you to access your widget 

tray. 
 
 
 
 
 
 
 
 
 
 
 

8. Click the arrows in the middle of the menu bar to drop down your widget tray 
 
 

 
 
 
 
 
 

9. Locate the Flickr Widget in the widget tray. Drag and drop the widget into the center of the blue box. 
 

 
10. Hover over the first white square and a pencil icon will appear, click on it and the Editing Widget window will appear. 

 
11. Click on the Search Tab. 
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12. Search Flickr for Photos to display. 

 
 

13. Select the Photos to add and then click on Add to Collection. 
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14. Click Collection Tab. 

 
 

15. From Collection Tab you can add descriptions images, reorder images and remove images. 
 

16. Click Properties Tab. 
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17. Pick the View mode, Column/Row, and Photo size. 

18. Click Save. 

19. To Preview the page before you publish it, go to the PageBuilder fly out menu bar and select View > Preview Layout. 
 

 
 

20. To return to Edit Page Layout Mode, select View > Return to Editing from the PageBuilder Menu bar. 
 

 
 

21. To Publish the page, select File > Publish from the PageBuilder Menu Bar. 
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22. The Flickr Gallery Page will like this. When visitors click on a photo it will take them to Flickrs photo page. 
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Create Video Page using YouTube 
Following instructions show you how to create a Video page using PageBuilder and YouTube Video widget. The videos are 
hosted on YouTube.com so you will need a YouTube account to manage your photos there. The YouTube Video widget simply 
acts as a display mechanism for the videos residing on YouTube. 

Exercise:  8-12 Create/Edit YouTube Video Page 
1. Follow same steps as Exercise: 8-10 above to create or edit a PageBuilder page customizing the title and alias to reflect the Video 

page. 

2. Perform Steps 7-10 of Exercise 8-11 except drag and drop the YouTube Video Widget into the dropzone. 

3. Click on the Search Tab. 
 

 
 

4. Select Text or Tag from Search by dropdown list. 

5. Enter in what you want to search for in the Search by field and run the search. 

6. Click on the Video Title of the video you want displayed. 

7. The YouTube Video you selected will be displayed. 
 



  

158 | P a g e  

 

 
 

8. To Preview the page before you publish it, go to the PageBuilder fly out menu bar and select View > Preview Layout. 
 

 
 

9. To return to Edit Page Layout Mode, select View > Return to Editing from the PageBuilder Menu bar. 
 

 
 

10. To Publish the page, select File > Publish from the PageBuilder Menu Bar. 
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11. The YouTube Video page will look like this. 
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Enhancing your Flickr or YouTube Page 
You can enhance your Multimedia pages using Flickr or YouTube Video by adding widgets that will display content, list boxes, 
and any other widgets that they wish to use. Below we will enhance the YouTube Video page by adding content about the 
Rocky Mountain Elk and adding the Browse by Subject Three Column List SmartForm content. 

1. Navigate to Your Refuge > Sections > Multimedia > Folder X where Folder X denotes folder that will contain 
your Flickr/YouTube pages and content. 

2. Add new HTML content following directions in Unit 14: Adding HTML Content. Below is sample HTML content 
for this instruction. 

 
 

3. Create a new Browse by Subject list using  Unit 14: Create/Edit a List using Three Column List SmartForm 
instructions or use the existing Browse by Subject content located in Your Refuge > Sections > Multimedia 
folder. 

4. Edit the page you want to enhance. Refer to Unit 14: Working with Content - Managing Content & Page - Edit 
PageBuilder Page for detailed instructions on how to edit the page. 
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5. Drag a Content Block widget above and below the Flickr or YouTube Video widget. 

 
 

6. Edit the Content Block widget 1 by clicking on the first white square. 

 
a. Ensure the Folder Tab is selected. 
b. Select the Folder that contains the content you want displayed. 
c. View Result will display all the contents in the selected folder. 
d. Select the content to add. 
e. Click Save. 

7. Edit Content Block widget 2 and repeat Step 6a – 6e above except select the Browse by Section Three Column 
List SmartForm content located in Your Refuge > Section > Multimedia folder. 
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8. Publish  the page and your page now looks like this: 
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Alternate Multimedia Landing Page 
The Multimedia Landing page (created using Multimedia Landing Page SmartForm) that is provided for you restricts you from 
adding Galleries created using PageBuilder page and Flickr/YouTube widgets, this is by design. An alternative method is to 
use the Promo SmartForm (Unit 5 Promo Page - How to Create & Edit) to create the Multimedia Landing page. Use the 
following steps for guidance: 

1. Create Multimedia Landing page using the Promo SmartForm. Refer to Unit 5 Promo Page - How to Create & Edit. 
2. Publish the new landing page. 
3. Edit the Homepage SmartForm content. Refer to Unit 10: Editing the Homepage. 
4. Update the Multimedia link so it links to the new landing page you created in Steps 1-2. Refer to Exercise 10-7:  

Color Shift, Alert, Maps & Multimedia. 
5. Publish the Homepage. 
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Unit 9 
Maps Page - How to 

Create & Edit 
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Overview 
Content Definition: The map page (persistent link) contains a consistent mapping tool that will be incorporated into the top 

portion of the illustration. Lower portion of the page lists other field station maps.  

Special Notes: Landmapper lite will be used and it is a flash application.  

Section Use: Maps 
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Exercises 
Exercise: 9-1 Setting Your Refuge/WMD Map 
In this exercise we will set the LIT/WMD code in the SWFObject widget so the correct map will appear on your maps page. 

 

1. Download and open the Spreadsheets with LIT codes (for Refuges) and ORG codes (for Wetland Management Destricts) found in 
the CMS Instructions folder in the Content Workarea. The spreadsheet will contain the code required to display your Refuge or 
WMD map. 

 
 

2. To edit your Map page navigate to Sections > Maps.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Choose Edit Page for your Refuge Map page. 
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4. Navigate to the swfobject Widget and hover the cursor over the first white square until a pencil icon appears and click on it. 

 
5. The swfobject property window will appear where you will update your LIT/WMD code. 

 
A. SWF URL will be provided for you. 

B. Flashvars field: Enter in your LIT code (for Refuges) or ORG code (for Wetland Management Destricts) that you 
obtained here. 

i. For Refuge: insert the LIT code after the “searchtext= Add your LIT code here”. For example: 
searchfield=LIT,searchtext=QVR,isequal=true 

ii. For WMD:  

1. Add “layernum=1” 

2. Change ‘searchfield=LIT’ to ‘searchfield=ORGCODE’ 

3. Add your ORG code after the “searchtext=Add your ORG code here” 

4. For example: layernum=1,searchfield=ORGCODE,searchtext=31731,isequal=true 
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C. Click Save in the swfobject widget to save the new code. 

6. On the Map PageBuilder page toolbar, click File>Publish to save and publish the page. 
NOTE: if you do not publish the map page your new LIT/WMD code you saved in the swfobject widget properties will not be 
saved and your map will not appear. 
 

  
 
NOTE: For questions about using LIT code or ORG code that does not display properly, contact Sean_Killen@fws.gov or 
Chris_Lett@fws.gov. 

 
 

 

 

 
  

shodala
Cross-Out
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Optional Exercises: For Advanced Users 
The following exercises are for advanced users for instances where a new Map page must be created from scratch. Situations 
where a new Map page would be required are if the existing Map page was accidentally deleted or corrupted. An alternative 
to creating a new Map page is to copy and paste a Map page from another Refuge. Instructions for Copy and Paste of content 
can be found in the Unit 14.  

Exercise: 9-2 Create/Edit Map Page 
In this exercise we will create/edit a Maps Page using PageBuilder.  
 
 

1. To edit the Map page. Navigate to Your Refuge > Section > Map folder and edit the page. Refer to Unit 14: Working 
with Content - Managing Content & Page - Edit PageBuilder Page for detailed instructions. Skip to Exercise: 9-3 
Add/Edit SWFObject Widget section below. 
 

2. To create a new Map page navigate to Sections > Maps.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Choose New > Page Layout 
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4. Add New Page: 

A. Choose three column layout 

B. Click Next 

 
 
 

5. Title, Aliasing, and Taxonomy: 

A. Enter a page title into the Page Title Field. This is the name of your content block. 

B. The alias field is automatically populated when you enter in a page title. Modify this alias so it follows the URL Aliasing 
Standards defined in Unite 3: URL Aliasing Standards. 

C. Click Next 
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6. Metadata  – Refer to Unit 14: Managing Content/Page Properties - Adding Metadata to add the Metadata. Click Finish when 
Metadata is completed 

 

7. Click OK 
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Exercise: 9-3 Add/Edit SWFObject Widget 
In this exercise we will add the SWFObject widget to your new page. To edit the widget, skip to Step 4. 

 
 

1. Click the arrow in the top left corner of the page to open the PageBuilder fly out menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Click the arrows in the middle of the menu bar. 
 
 
 
 
 
 
 

3. Find the swfobject widget in the widget tray. Drag and drop the swfobject widget into the center of the box. 

 

 

 

 

 

 

 

 

 

 

 

4. Hover over the first white square and a pencil icon will appear click on it. 

 
5. The swfobject widget properties windows will appear, refer to exercise 9-1 on instructions on updating LIT/WMD codes. 
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Exercise: 9-4 Additional Maps 

 

1. Click the arrow in the top left corner of the page to open the PageBuilder fly out menu. This will allow you to access your widget 
tray. 

 
 
 
 
 
 
 
 
 
 

2. Click the arrows in the middle of the menu bar to drop down your widget tray 
 
 
 
 

 
 

3. Drag and drop your Content Block widget down to create your additional links.  

 
4. Hover over the first white square and a pencil icon will appear click on it. 
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5. Make sure your content tab is highlighted 

6. Navigate down to NWRS > Your Refuge > Sections > Maps. 

7. Click the Additional Maps Content that was created using Three Column List SmartForm. For instructions on how to create a list 
content using Three Column List SmartForm go to: Unit 14: Create/Edit a List using Three Column List SmartForm. 

8. Click Save. 

 

  
 

9. Go to File > Publish. 
  


