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1.0 ArcGIS Pro – Version 3.2.0 
1.1 Start a New Project Template 
Start an ArcGIS Pro (Pro) Map Template by selecting Map from the Blank Templates list. Give the project a 
unique name (ex: La Crosse FWCO eDNA 2024) and specify the location of where to store the Pro project 
file and create a folder if needed to store the project file and eDNA field data. Click Ok when finished. 

1.2 Folder Connections 
The folder specified to store your project file will automatically show under the Folders option in the Catalog 
Pane, If the Catalog Pane does not appear on the right side in Pro, Go to the View Tab and Select Catalog 
Pane in the Windows group. 

 
1) To establish a new folder connection, right-click on Folders in the Catalog Pane and select “Add 

Folder Connection” to link to a folder on the computer. 

 
2) A “Connect To Folder” window will appear which will allow you to navigate and select the folder of 

interest. Click “Ok” and the folder will be added to the Catalog Pane under Folders.  
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3) To Connect to a Folder not stored on the Computer, Copy the folder path to the folder of interest and 

paste the path into the Name box and click Ok. The folder will be added to the Catalog Pane under 
Folders. 

2.0 eDNA Fisheries ArcGIS Online Web Map 
2.1 Access ArcGIS eDNA Fisheries Online Web Map 

1) To access the online Fisheries eDNA Sampling map through Pro, the individual needs to be logged 
into the ArcGIS Online account by going to the top right-hand corner of the Pro screen and expand the 
Not signed in menu (see below). Select Sign In. The sign in process is the same as signing into the 
Field Maps App (refer to Field Maps App Log in Section 1.2). 

 
2) After signing in, go to the Catalog Pane, select “Portal” from the top menu (see below). 
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3) Next, select the “My Groups” icon. 

 
4) In the search bar, type in Fisheries “eDNA Sampling” and hit enter. Right-click on the “FWS Region 3 

Fisheries eDNA Sampling Map 2024” to open the map in Pro (see below). 
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3.0 Select and QA/QC Individual Office eDNA Data 
3.1 Common Errors Checklist 
Common errors to look for in the Invasive Carp eDNA field data feature layer when conducting QA/QC 
checks in ArcGIS Pro. 

1) Check the map and ensure all your sample points are displaying on the target waterbody. 
2) Snap blank samples to the appropriate field data point if not already snapped. 
3) Check state line layer in map to ensure the correct state has been identified for the sampling point. 
4) Check for null values in each data field. 
5) Check the date collected column for any dates and times outside of the date/time range of collection. 
6) Look for repeat Regional Unique IDs. 
7) Be sure “Calculate Geometry” has been run on the Latitude and Longitude fields. 
8) Please make note of any environmental conditions that may affect the quality of the samples in the 

comments field. 

3.2 Create Local Copy for Editing. 
A local copy of the data needs to be created before editing the eDNA sample points. 

1) Click the “FWS Region 3 Fisheries eDNA Sampling Map” tab to activate, if not already active (tab 
should be highlighted in blue). 

2) Zoom in to the extent of the sampling points. Make sure all the sampling points can be viewed in the 
map extent. It is imperative to zoom-in to the area of interest that needs to be edited. The local copy 
that is created will be based off the current extent displayed in ArcGIS Pro. 

 
3) Next, created an offline version of the map by selecting “Download” under the “Download Map” tool 

in the Offline group under the Map tab in Pro (leave “Include basemap & tile layers” unchecked) (see 
image below). 
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4) The offline map download is successful if the “Sync” and “Remove” options are no longer greyed out 
under the Offline Group (see image below). 

 
Important! Double check to make sure only the targeted office data has been downloaded by using the Select 
by Attributes tool to check the Sampling Station ID Code field only has one office value (La Crosse FWCO, 
Ashland FWCO, etc.). Sampling Points are also color coded by sampling Basin. See Section 3.3.2 Select by 
Attributes. 

3.3 QA/QC of eDNA Data: Identifying Data Issues in Pro 
3.3.1 Attribute Table 

1) Right-click on the feature layer to open the attribute table (see image below). 

 
2) Right-click on each field to sort the data ascending and descending to check for null or incorrect 

values (see images below). 
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3) To fix a data value, click on the data record in the table to edit the value. To batch edit records see 

section for “Field Calculator”. Pay attention to the date and time fields and ensure both are accurate 
(see image below). 
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4) After making changes to the table, go the “Edit” tab in the top ribbon of Pro. Select “Save” under the 

Manage Edits group to save any edits that have been made to attributes. Use the “Discard” button to 
undo any recent edits that have been made. 

 
3.3.2 Select by Attributes 

1) Right-click on the feature layer to open the attribute table (see image below). 
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2) Select the “Select by Attributes” tool in the table header (see image below). “Select by Attributes” can 

also be accessed in the Map tab under the Selection group in Pro. 

 
3) The “Select by Attributes” tool can be used to query for certain records in the database to check for 

null values or check for data accuracy. In this example, a new expression can be selected, and the field 
(RUID) can be selected from the list for “Where” and “is equal to” can be selected for the expression 
and the value list can be used to view the unique values for the RUID field (see image below). 
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4) A value for RUID can then be selected from the list of values. Select “Apply” to highlight the record 

in the table (see image below). 

 
5) Check for null values in the data by setting the expression to “is null” (see image below). 
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Null values can also be found using the ascending and descending functions for each field see Section 
3.3.1. Run this expression on each of the data fields to make sure data is complete. If running the 
expression doesn’t highlight any of the records, then the data has a value entered for the respective field. 

 
6) Use the “Select by Attributes” on multiple fields to check records for completeness and accuracy. The 

“Add Clause” can be used in the tool to select more than one record by using the “Or” or “And” 
clauses (see image above). 

3.3.3 Find Duplicate Records 
1) Go to the Analysis tab in the top ribbon. Select “Tools” from the Geoprocessing group (see image 

below). 

 
2) Use the “Find Tools” search box in the Geoprocessing pane to locate the “Find Identical” tool. 
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3) Select the “Find Identical” tool. Input the Feature Layer and navigate to a folder to store the output 

dataset. Input the Regional Unique ID as the field. Check the box “Output only duplicate records” (see 
image below). Select “Run”. 

 
4) If no identical values are found, the tool will complete with a warning: “Find Identical tool completed 

with warnings.” Check the View Details and expand the messages group to ensure “No duplicate(s) 
found” (see images below). The output table will have no records in it when opened. 
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5) If there are identical values in Regional Unique ID field, the tool will complete successfully with no 

warning messages. 
6) Open the output table in the Contents Pane in Pro by right-clicking the table and selecting “Open” (see 

image below). 

 
7) If there were duplicate records, the IN_FID field matches to the OBJECTID field from the input 

dataset and the FEAT_SEQ groups the same duplicate records by number (see image below). For 
example, IN_FID (OBJECTID) 7 and 8 are the sample duplicate record due to the “1” appearing in 
each of the FEAT_SEQ cells. 
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3.4 QA/QC of eDNA Data: Editing in Pro 
3.4.1 Using the “Calculate Field” tool 

1) Use the “Calculate Field” tool to change multiple records at once. Select the records that need to be 
changed through “Select by Attribute” or by manually selecting the gray boxes by each record, then 
right click on the field of interest and select “Calculate Field” (see image below). 

 
2) Enter the information that will populate the selected records in the blank box and keep all the default 

settings in the Calculate Field window (see below). If the information is text, put quotes around the 
text. Make sure to enable “Use the selected records” and “Enable Undo” by toggling to blue. Select 
“Ok” to change the records (see image below). 
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3) Then, only the selected records will have the changed information from the “Calculate Field” tool (see 

below). Clear the selection in the attribute table or under the Selection group in the Map tab. 

 
4) “Save” Edits under the Edit tab in Pro or “Discard” edits if a mistake was made. 
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3.4.2 Calculate Geometry 
1) Use the “Calculate Geometry” tool to populate the Latitude and Longitude fields (see image below). If 

a point is added or moved after running “Calculate Geometry”, the coordinates need to be updated 
in the latitude and longitude fields (re-run the “Calculate Geometry” tool). 

 
2) To update latitude and longitude values, right-click on either the Latitude or Longitude fields and 

select “Calculate Geometry” (see image above). 
3) Enter in Latitude and Longitude for the Target fields with “Point y-coordinate” for Latitude and “Point 

x-coordinate” for Longitude. Set the Coordinate Format to “Decimal Degrees” and select Ok (see 
image below). 
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4) The coordinates will be updated in the Latitude and Longitude fields. 

3.4.3 Creating a Feature Point 
If a sample point was not submitted in the field or is missing, a point can be created for that sample in Pro 
(see image below). 
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1) Go to the Edit tab in the project. Click on the “Create Features” tool under the Features Group (see 

image above). 
2) The “Create Features” panel will appear on the right side of the project. Select one of the appropriate 

Basins to add a new feature under the FWS Region 3 Fisheries eDNA Sampling Feature Layer to add 
a point to the map. 

 
3) Next, use the “Active Template” to fill out whether the sample is a blank or not. Then, click a spot on 

the map to add the new point (see image below). 
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4) Use the Active Template (image above) or the Attribute Table to fill out the rest of the tabular data (see 

image below). 

 
If there are specific coordinates associated with the sample point then the Absolute X, Y, Z option can be used 
to add them. 

1) Open the “Create Features” panel. 
2) Select “New Feature” in the panel and right-click anywhere on the map. Choose “Absolute X, Y, Z”. 
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3) In the Absolute X, Y window, use the drop-down arrow to select decimal degrees (dd). 
4) Enter the latitude and longitude of the point and press enter when finished. The point will appear in the 

specified location. 

 
Make sure to leave the W and N at the end of each coordinate and leave the negative sign out for the 
Longitude. 

5) “Save” Edits under the Manage Edits group or “Discard” if a mistake was made. Exit the “Create 
Features” panel to stop adding new features. Important! Update coordinates using “Calculate 
Geometry.” 

3.4.4 Moving a Feature Point 
1) Turn off the State Reference layer in the Contents Panel (see image below). 
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2) To move a sample point, use the “Select” tool under the Selection group under the Edit tab and select 

the point.  
3) Next, Select the “Move” tool under the tools group in the Edit tab. 
4) Use the mouse to click and drag the point to a new location on the map. Select the “Finish” option in 

the tool dialog box to change the location of the point. Important! Update the coordinates using 
“Calculate Geometry”. Save the Edits. 

 
5) If the point has a specific coordinate location that it needs to be moved to, right-click the selected 

point, and select the “Edit Vertices” option (see image below). 



Page 23 of 26 
 

 
6) An “Edit Vertices” panel should appear. Next, hover the mouse arrow over the selected point until an 

arrow icon appears. Then, right-click the point to bring up an options window. 
7) Select the “Move To” option in the options window (see image below). 

 
8) In the “Move To” window, use the drop down arrow to select decimal degrees (dd). Enter the latitude 

and longitude of the point and press enter when finished. 
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9) The point will appear in the specified location. A highlighted point will remain in the previous place 
the point was located and can be removed by selecting “Clear” selection under the Selection group 
under the Edit tab, or by right-clicking on the selected point and selecting “Move”. Important! 
Update coordinate using “Calculate Geometry”. 

3.4.5 Snapping Feature Points Together 
1) Enable “Snapping” under the Snapping group under the Edit tab. Make sure “Snapping” is toggled on 

and the point snap option is on (highlighted in blue when enabled). 

 
2) Follow Section 3.4.4 to move a sample point on top of another sample point to snap the points 

together. A circle will appear around the point being snapped to (see below). Once snapped, the points 
will share the exact same latitude and longitude. Important! Update coordinates using “Calculate 
Geometry”. 

 
3.4.6 Appending Data to Geodatabase (Field Maps App or iPad failure) 

1) If data needed to be collected outside of the Field Maps App due to a severe technical issue, record the 
data on a paper data sheet and transcribe the field data to the provided excel sheet located on the R3 
eDNA SharePoint site under ArcGIS Resources. 

Note: If needed, coordinates can be captured as Waypoints on a Fish Finder. Match the waypoint number to 
the eDNA sample number to keep track of sample locations. Export the Waypoints to add the coordinates to 
the provided excel sheet. Enter the name of the device and datum used to capture waypoints in the 
“Comments” field. 
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2) QA/QC the data in Excel using similar tools such as “Sort” and “Find and Replace” to identify null 
values, duplicate RUID values, and incorrect data entries. Double-check coordinates. 

3) Send the QA/QC’ed Excel file to the eDNA database manager, Ross Ruehmann 
(ross_ruehmann@fws.gov). The data will be added to the final database on the FWS Enterprise 
Warehouse and in AGOL if the data is reportable. 

4.0 Uploading QA/QC eDNA Data to ArcGIS Online 
1) Once all the edits have been made, “Save” edits under the Edit tab in the Manage Edits group. 
2) Optional: Export either a table or feature layer of the final data to your office data repository by right 

clicking on the feature layer and selecting the data option to either export a feature layer or a table (see 
next page). Or use the “Table to Excel” tool. Make sure to select the “Domain and Subtype 
Description” option in the “Table to Excel” tool (see images below). 

Note: Make sure the selection is cleared before exporting the data. Make sure non-reportable data is 
not shared with the public unless permission is given by the eDNA Coordinator. 
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3) The data can then be uploaded back to ArcGIS Online (AGOL) by going to the map tab 
and selecting “Sync” under the Offline group. 

 
4) Check under your default folder in the Catalog Panel to make sure file geodatabase is 

gone after successfully enabling “Sync”. If it’s not gone, manually delete the file 
geodatabase. 

 
5) Save the Pro Project with the FWS R3 Fisheries eDNA Sampling Map to use again for 

future editing. Re-add the map if newly created feature points do not appear. 
Note: When accessing the online web map, make sure to download a local copy of the data 
when editing is needed. Previously downloaded local copies may not reflect data that has 
been collected after the local copy was created. 
Note: Make sure to either Remove or Sync the feature layer to AGOL when finished with the 
editing process. Please don’t leave mobile geodatabases unresolved on the computer. 
*Non-reportable data is any data not published to the public facing AGOL feature layer 
or the U.S. Fish and Wildlife Service eDNA website. 
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